Read the docs
TI-2024-34474 Aliases CVE-2024-51559GHSA-hjhx-mr4r-6j6j

Improper Access Control Vulnerability in Wave 2.0

Priority LOW 31CWE-639Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Security bypass
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-639.

Summary

This vulnerability exists in the Wave 2.0 due to improper authorization checks on certain API endpoints. An authenticated remote attacker could exploit this vulnerability by manipulating API input parameters to gain unauthorized access and perform malicious activities on other user accounts.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0034 27th percentileScored 2026-11-07
Fix Fixed Wave 2.0 (Brokerage Technology Solutions): 1.1.7

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Brokerage Technology SolutionsWave 2.0before 1.1.71.1.7Patch availableCNA

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:63moons:aero:*:*:*:*:*:*:*:*before 120820241550VulnerableBrokerage Technology Solutions
cpe:2.3:a:63moons:wave_2.0:*:*:*:*:*:*:*:*before 1.1.7VulnerableBrokerage Technology Solutions

Remediation

  • Fix · CNA Wave 2.0 (Brokerage Technology Solutions) Fixed in 1.1.7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-51559
  2. 2026-10-03 Alias added: GHSA-hjhx-mr4r-6j6j

References

  • TI-2024-34476 Authentication bypass Vulnerability in Aero CVSS 4.0CRITICAL 9.3
  • TI-2024-34473 Brute Force Attack Vulnerability in Wave 2.0 CVSS 4.0CRITICAL 9.3
  • TI-2024-34472 No Rate Limiting Vulnerability in Wave 2.0 CVSS 4.0HIGH 7.1
  • TI-2024-34475 Improper Error Handling Vulnerability in Wave 2.0 CVSS 4.0HIGH 7.1
  • TI-2024-34471 Sensitive Information Disclosure Vulnerability in Wave 2.0 CVSS 4.0HIGH 7.1

Sources