SQL injection in RTI Connext Professional
Priority MEDIUM 45CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-89.
Summary
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in RTI Connext Professional (Queuing Service) allows SQL Injection.This issue affects Connext Professional: from 7.0.0 before 7.3.0, from 6.1.0 before 6.1.2.17, from 6.0.0 before 6.0.*, from 5.2.0 before 5.3.*.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00408 35th percentileScored 2026-11-07
Fix Fixed Connext Professional (RTI): 7.3.0, 6.1.2.17
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Connext Professional (RTI) Fixed in 7.3.0, 6.1.2.17
Timeline
- 2026-10-02 Threatist record created from CVE-2024-52057
- 2026-10-03 Alias added: GHSA-fqh4-5w83-h9mv
References
More RTI Connext Professional vulnerabilities
- TI-2021-16087 Potential Network Amplification and Information Exposure in RTI Connext Professional and Connext Micro CVSS 4.0HIGH 8.8
- TI-2026-03368 Out-of-bounds read in RTI Connext Professional CVSS 4.0CRITICAL 9.2
- TI-2026-02096 Heap-based buffer overflow in RTI Connext Professional CVSS 4.0CRITICAL 9.2
- TI-2021-16038 RTI Connext DDS Professional and Connext DDS Secure Incorrect Calculation of Buffer Size CVSS 3.1CRITICAL 9.8
- TI-2026-06407 Buffer overflow in RTI Connext Professional CVSS 4.0HIGH 8.8
- TI-2024-34942 Potential stack corruption in Routing Service when using a malicious XML configuration document CVSS 4.0HIGH 8.3
Sources
- CVE-2024-52057 · CVE Program
- CVE-2024-52057 · NVD
- FIRST EPSS
- GHSA-fqh4-5w83-h9mv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences