Rancher Helm Applications may have sensitive values leaked
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
A Exposure of Sensitive Information to an Unauthorized Actor vulnerability in SUSE rancher allowing any users with GET access to the Rancher Manager Apps Catalog to read any sensitive information that are contained within the Apps’ values. Additionally, the same information leaks into auditing logs when the audit level is set to equal or above 2. This issue affects rancher: from 2.8.0 before 2.8.10, from 2.9.0 before 2.9.4.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | rancher | 2.8.0 to before 2.8.10; 2.9.0 to before 2.9.4 | 2.8.10, 2.9.4 | Patch available | CNA |
| — | github.com/rancher/rancher (Go) | 2.8.0 to before 2.8.10 | 2.8.10 | Patch available | GHSA-9c5p-35gj-jqp4 |
| — | github.com/rancher/rancher (Go) | 2.9.0 to before 2.9.4 | 2.9.4 | Patch available | GHSA-9c5p-35gj-jqp4 |
- rancher VendorSUSE Affected 2.8.0 to before 2.8.10; 2.9.0 to before 2.9.4 Fixed in 2.8.10, 2.9.4 Patch available CNA
- github.com/rancher/rancher (Go) Vendor— Affected 2.8.0 to before 2.8.10 Fixed in 2.8.10 Patch available GHSA-9c5p-35gj-jqp4
- github.com/rancher/rancher (Go) Vendor— Affected 2.9.0 to before 2.9.4 Fixed in 2.9.4 Patch available GHSA-9c5p-35gj-jqp4
Remediation
- Fix · CNA rancher (SUSE) Fixed in 2.8.10, 2.9.4
- Fix · GHSA-9c5p-35gj-jqp4 github.com/rancher/rancher (Go) Fixed in 2.8.10 Advisory →
- Fix · GHSA-9c5p-35gj-jqp4 github.com/rancher/rancher (Go) Fixed in 2.9.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-52282
- 2026-10-03 Alias added: GHSA-9c5p-35gj-jqp4
References
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-52282 · CVE Program
- CVE-2024-52282 · NVD
- FIRST EPSS
- GHSA-9c5p-35gj-jqp4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences