Improper privilege management in nextcloud security-advisories
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-269.
Summary
Nextcloud Server is a self hosted personal cloud system. When a server is configured to only allow sharing with users that are in ones own groups, after a user was removed from a group, previously shared items were not unshared. It is recommended that the Nextcloud Server is upgraded to 22.2.11 or 23.0.11 or 24.0.6 and Nextcloud Enterprise Server is upgraded to 22.2.11 or 23.0.11 or 24.0.6.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| nextcloud | security-advisories | 28.0.0 to before 28.0.9; 29.0.0 to before 29.0.5 | 28.0.9, 29.0.5 | Patch available | CNA |
- security-advisories Vendornextcloud Affected 28.0.0 to before 28.0.9; 29.0.0 to before 29.0.5 Fixed in 28.0.9, 29.0.5 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* | 26.0.0 to before 26.0.13.9; 27.0.0 to before 27.1.11.9 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:*:*:*:* | 28.0.0 to before 28.0.9 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* | 28.0.0 to before 28.0.9 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:*:*:*:* | 29.0.0 to before 29.0.5 | Vulnerable | nextcloud |
| cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* | 29.0.0 to before 29.0.5 | Vulnerable | nextcloud |
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* Versions 26.0.0 to before 26.0.13.9; 27.0.0 to before 27.1.11.9 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:*:*:*:* Versions 28.0.0 to before 28.0.9 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* Versions 28.0.0 to before 28.0.9 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:*:*:*:* Versions 29.0.0 to before 29.0.5 Vulnerable ·nextcloud
- cpe:2.3:a:nextcloud:nextcloud_server:*:*:*:*:enterprise:*:*:* Versions 29.0.0 to before 29.0.5 Vulnerable ·nextcloud
Remediation
- Fix · CNA security-advisories (nextcloud) Fixed in 28.0.9, 29.0.5
Timeline
- 2026-10-02 Threatist record created from CVE-2024-52516
References
More Nextcloud Server vulnerabilities
- TI-2023-20855 Users can delete external storage mount points CVSS 3.1HIGH 7.7
- TI-2023-11091 Nextcloud download permissions can be changed by resharer CVSS 3.1HIGH 7.5
- TI-2023-10624 Nextcloud Server vulnerable to SSRF via filter bypass due to lax checking on IPs CVSS 3.1MEDIUM 5.3
- TI-2025-37238 Cross-site scripting in Nextcloud CVSS 3.1MEDIUM 6.4
- TI-2023-11086 nextcloud vulnerable to Uncontrolled Resource Consumption CVSS 3.1MEDIUM 6.5
- TI-2022-18738 Exception logging in Sharepoint app reveals clear-text connection details CVSS 3.1MEDIUM 6.5
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences