Cross-site Scripting vulnerability with prototype pollution in vue-i18n
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
vue-i18n is an internationalization plugin for Vue.js. In affected versions vue-i18n can be passed locale messages to `createI18n` or `useI18n`. When locale message ASTs are generated in development mode there is a possibility of Cross-site Scripting attack. This issue has been addressed in versions 9.14.2, and 10.0.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| intlify | vue-i18n | before 9.14.2; 10.0.0 to before 10.0.5 | 9.14.2, 10.0.5 | Patch available | CNA |
| — | @intlify/core-base (npm) | 9.3.0 to before 9.14.2 | 9.14.2 | Patch available | GHSA-9r9m-ffp6-9x4v |
| — | vue-i18n (npm) | 9.3.0 to before 9.14.2 | 9.14.2 | Patch available | GHSA-9r9m-ffp6-9x4v |
| — | @intlify/core (npm) | 9.3.0 to before 9.14.2 | 9.14.2 | Patch available | GHSA-9r9m-ffp6-9x4v |
| — | @intlify/vue-i18n-core (npm) | 9.3.0 to before 9.14.2 | 9.14.2 | Patch available | GHSA-9r9m-ffp6-9x4v |
| — | petite-vue-i18n (npm) | 10.0.0 to before 10.0.5 | 10.0.5 | Patch available | GHSA-9r9m-ffp6-9x4v |
| — | @intlify/core-base (npm) | 10.0.0 to before 10.0.5 | 10.0.5 | Patch available | GHSA-9r9m-ffp6-9x4v |
| — | vue-i18n (npm) | 10.0.0 to before 10.0.5 | 10.0.5 | Patch available | GHSA-9r9m-ffp6-9x4v |
| — | @intlify/core (npm) | 10.0.0 to before 10.0.5 | 10.0.5 | Patch available | GHSA-9r9m-ffp6-9x4v |
| — | @intlify/vue-i18n-core (npm) | 10.0.0 to before 10.0.5 | 10.0.5 | Patch available | GHSA-9r9m-ffp6-9x4v |
- vue-i18n Vendorintlify Affected before 9.14.2; 10.0.0 to before 10.0.5 Fixed in 9.14.2, 10.0.5 Patch available CNA
- @intlify/core-base (npm) Vendor— Affected 9.3.0 to before 9.14.2 Fixed in 9.14.2 Patch available GHSA-9r9m-ffp6-9x4v
- vue-i18n (npm) Vendor— Affected 9.3.0 to before 9.14.2 Fixed in 9.14.2 Patch available GHSA-9r9m-ffp6-9x4v
- @intlify/core (npm) Vendor— Affected 9.3.0 to before 9.14.2 Fixed in 9.14.2 Patch available GHSA-9r9m-ffp6-9x4v
- @intlify/vue-i18n-core (npm) Vendor— Affected 9.3.0 to before 9.14.2 Fixed in 9.14.2 Patch available GHSA-9r9m-ffp6-9x4v
- petite-vue-i18n (npm) Vendor— Affected 10.0.0 to before 10.0.5 Fixed in 10.0.5 Patch available GHSA-9r9m-ffp6-9x4v
- @intlify/core-base (npm) Vendor— Affected 10.0.0 to before 10.0.5 Fixed in 10.0.5 Patch available GHSA-9r9m-ffp6-9x4v
- vue-i18n (npm) Vendor— Affected 10.0.0 to before 10.0.5 Fixed in 10.0.5 Patch available GHSA-9r9m-ffp6-9x4v
- @intlify/core (npm) Vendor— Affected 10.0.0 to before 10.0.5 Fixed in 10.0.5 Patch available GHSA-9r9m-ffp6-9x4v
- @intlify/vue-i18n-core (npm) Vendor— Affected 10.0.0 to before 10.0.5 Fixed in 10.0.5 Patch available GHSA-9r9m-ffp6-9x4v
Remediation
- Fix · CNA vue-i18n (intlify) Fixed in 9.14.2, 10.0.5
- Fix · GHSA-9r9m-ffp6-9x4v @intlify/core-base (npm) Fixed in 9.14.2 Advisory →
- Fix · GHSA-9r9m-ffp6-9x4v vue-i18n (npm) Fixed in 9.14.2 Advisory →
- Fix · GHSA-9r9m-ffp6-9x4v @intlify/core (npm) Fixed in 9.14.2 Advisory →
- Fix · GHSA-9r9m-ffp6-9x4v @intlify/vue-i18n-core (npm) Fixed in 9.14.2 Advisory →
- Fix · GHSA-9r9m-ffp6-9x4v petite-vue-i18n (npm) Fixed in 10.0.5 Advisory →
- Fix · GHSA-9r9m-ffp6-9x4v @intlify/core-base (npm) Fixed in 10.0.5 Advisory →
- Fix · GHSA-9r9m-ffp6-9x4v vue-i18n (npm) Fixed in 10.0.5 Advisory →
- Fix · GHSA-9r9m-ffp6-9x4v @intlify/core (npm) Fixed in 10.0.5 Advisory →
- Fix · GHSA-9r9m-ffp6-9x4v @intlify/vue-i18n-core (npm) Fixed in 10.0.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-52809
- 2026-10-03 Alias added: GHSA-9r9m-ffp6-9x4v
References
More intlify vulnerabilities
- TI-2025-20407 Vue I18n Prototype Pollution in `handleFlatJson` CVSS 4.0HIGH 8.9
- TI-2024-35322 Prototype Pollution in @intlify/shared >=9.7.0 <= 10.0.4 CVSS 4.0MEDIUM 6.9
- TI-2025-33767 Intlify Vue I18n's escapeParameterHtml does not prevent DOM-based XSS via tag attributes like onerror CVSS 4.0MEDIUM 5.3
- TI-2026-82143 Vue I18n escapeParameter misses named values when a list is passed CVSS 4.0LOW 2.1
- TI-2026-82144 Cross-site scripting in Vue I18n translations through iframe srcdoc CVSS 3.1HIGH 7.2
Sources
- CVE-2024-52809 · CVE Program
- CVE-2024-52809 · NVD
- FIRST EPSS
- GHSA-9r9m-ffp6-9x4v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences