NFSD: Prevent a potential integer overflow
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Partial Red Hat: 5 fixed, 3 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: NFSD: Prevent a potential integer overflow If the tag length is >= U32_MAX - 3 then the "length + 4" addition can result in an integer overflow. Address this by splitting the decoding into several steps so that decode_cb_compound4res() does not have to perform arithmetic on the unsafe length value.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 2.6.12 and later | 4.19.325, 5.4.287, 5.10.231, 5.15.174, 6.1.120, 6.6.64, 6.11.11, 6.12.2, 6.13 | Patch available | CNA |
- Linux VendorLinux Affected 2.6.12 and later Fixed in 4.19.325, 5.4.287, 5.10.231, 5.15.174, 6.1.120, 6.6.64, 6.11.11, 6.12.2, 6.13 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | before 4.19.325; 4.20 to before 5.4.287; 5.5 to before 5.10.231; 5.11 to before 5.15.174; 5.16 to before 6.1.120; 6.2 to before 6.6.64; 6.7 to before 6.11.11; 6.12 to before 6.12.2 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions before 4.19.325; 4.20 to before 5.4.287; 5.5 to before 5.10.231; 5.11 to before 5.15.174; 5.16 to before 6.1.120; 6.2 to before 6.6.64; 6.7 to before 6.11.11; 6.12 to before 6.12.2 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 4.19.325, 5.4.287, 5.10.231, 5.15.174, 6.1.120, 6.6.64, 6.11.11, 6.12.2, 6.13
Red Hat 1 advisory
- RHSA-2025:6966 Released 2025-05-13 · Red Hat rating Moderatekernel security update
- Red Hat Enterprise Linux AppStream (v. 9) kernel-64k-debug-devel-5.14.0-570.12.1.el9_6, kernel-64k-debug-devel-matched-5.14.0-570.12.1.el9_6, kernel-64k-devel-5.14.0-570.12.1.el9_6 +12
- Red Hat Enterprise Linux BaseOS (v. 9) kernel-5.14.0-570.12.1.el9_6, kernel-64k-5.14.0-570.12.1.el9_6, kernel-64k-core-5.14.0-570.12.1.el9_6 +28
- Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) kernel-tools-libs-devel-5.14.0-570.12.1.el9_6, libperf-5.14.0-570.12.1.el9_6
- Red Hat Enterprise Linux Real Time (v. 9) kernel-rt-5.14.0-570.12.1.el9_6, kernel-rt-64k-5.14.0-570.12.1.el9_6, kernel-rt-64k-core-5.14.0-570.12.1.el9_6 +21
- Red Hat Enterprise Linux Real Time for NFV (v. 9) kernel-rt-5.14.0-570.12.1.el9_6, kernel-rt-core-5.14.0-570.12.1.el9_6, kernel-rt-debug-5.14.0-570.12.1.el9_6 +11
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2025:6966 |
| Red Hat Enterprise Linux BaseOS (v. 9) | Fixed | RHSA-2025:6966 |
| Red Hat Enterprise Linux CodeReady Linux Builder (v. 9) | Fixed | RHSA-2025:6966 |
| Red Hat Enterprise Linux Real Time (v. 9) | Fixed | RHSA-2025:6966 |
| Red Hat Enterprise Linux Real Time for NFV (v. 9) | Fixed | RHSA-2025:6966 |
Timeline
- 2026-10-02 Threatist record created from CVE-2024-53146
- 2026-10-03 Alias added: GHSA-rw8v-g4fm-gw3v
- 2026-10-29 Affected versions changed · Red Hat
References
Patch 9
- https://git.kernel.org/stable/c/745f7ce5a95e783ba62fe774325829466aec2aa8
- https://git.kernel.org/stable/c/90adbae9dd158da8331d9fdd32077bd1af04f553
- https://git.kernel.org/stable/c/3c5f545c9a1f8a1869246f6f3ae8c17289d6a841
- https://git.kernel.org/stable/c/842f1c27a1aef5367e535f9e85c8c3b06352151a
- https://git.kernel.org/stable/c/de53c5305184ca1333b87e695d329d1502d694ce
- https://git.kernel.org/stable/c/dde654cad08fdaac370febb161ec41eb58e9d2a2
- https://git.kernel.org/stable/c/084f797dbc7e52209a4ab6dbc7f0109268754eb9
- https://git.kernel.org/stable/c/ccd3394f9a7200d6b088553bf38e688620cd27af
- https://git.kernel.org/stable/c/7f33b92e5b18e904a481e6e208486da43e4dc841
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-53146 · CVE Program
- CVE-2024-53146 · NVD
- FIRST EPSS
- GHSA-rw8v-g4fm-gw3v · GitHub Advisory Database · CC BY 4.0
- CVE-2024-53146 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences