Apache Wicket: An attacker can intentionally trigger a memory leak
Priority LOW 32CWE-400Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
The request handling in the core in Apache Wicket 7.0.0 on any platform allows an attacker to create a DOS via multiple requests to server resources. Users are recommended to upgrade to versions 9.19.0 or 10.3.0, which fixes this issue.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01502 74th percentileScored 2026-11-07
Fix Fixed org.apache.wicket:wicket-core (Maven): 8.17.0, 10.3.0, 9.19.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Wicket | 7.0.0 and later; 8.0.0-M1 and later; 9.0.0-M1 and later; 10.0.0-M1 and later | — | No fix listed | CNA |
| — | org.apache.wicket:wicket-core (Maven) | 7.0.0 to before 8.17.0 | 8.17.0 | Patch available | GHSA-9cxr-76pm-j3wf |
| — | org.apache.wicket:wicket-core (Maven) | 10.0.0 to before 10.3.0 | 10.3.0 | Patch available | GHSA-9cxr-76pm-j3wf |
| — | org.apache.wicket:wicket-core (Maven) | 9.0.0-M1 to before 9.19.0 | 9.19.0 | Patch available | GHSA-9cxr-76pm-j3wf |
- Apache Wicket VendorApache Affected 7.0.0 and later; 8.0.0-M1 and later; 9.0.0-M1 and later; 10.0.0-M1 and later Fixed in — No fix listed CNA
- org.apache.wicket:wicket-core (Maven) Vendor— Affected 7.0.0 to before 8.17.0 Fixed in 8.17.0 Patch available GHSA-9cxr-76pm-j3wf
- org.apache.wicket:wicket-core (Maven) Vendor— Affected 10.0.0 to before 10.3.0 Fixed in 10.3.0 Patch available GHSA-9cxr-76pm-j3wf
- org.apache.wicket:wicket-core (Maven) Vendor— Affected 9.0.0-M1 to before 9.19.0 Fixed in 9.19.0 Patch available GHSA-9cxr-76pm-j3wf
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:wicket:*:*:*:*:*:*:*:* | 7.0.0 – 7.18.0; 8.0.0 – 8.16.0; 9.0.0 to before 9.19.0; 10.0.0 to before 10.3.0 | Vulnerable | Apache |
- cpe:2.3:a:apache:wicket:*:*:*:*:*:*:*:* Versions 7.0.0 – 7.18.0; 8.0.0 – 8.16.0; 9.0.0 to before 9.19.0; 10.0.0 to before 10.3.0 Vulnerable ·Apache
Remediation
- Fix · GHSA-9cxr-76pm-j3wf org.apache.wicket:wicket-core (Maven) Fixed in 8.17.0 Advisory →
- Fix · GHSA-9cxr-76pm-j3wf org.apache.wicket:wicket-core (Maven) Fixed in 10.3.0 Advisory →
- Fix · GHSA-9cxr-76pm-j3wf org.apache.wicket:wicket-core (Maven) Fixed in 9.19.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-53299
- 2026-10-03 Alias added: GHSA-9cxr-76pm-j3wf
References
More Apache Wicket vulnerabilities
- TI-2016-05834 The DiskFileItem class in Apache Wicket 6.x before 6.25.0 and 1.5.x before 1.5.17 allows… CVSS 3.0CRITICAL 9.1
- TI-2026-28853 Apache Wicket: possible session fixation using AuthenticatedWebSession CVSS 3.1CRITICAL 9.1
- TI-2024-24295 Apache Wicket: Remote code execution via XSLT injection CVSS 3.1CRITICAL 9.8
- TI-2026-49926 Apache Wicket: Configured file upload limits are not enforced when the multipart request has already been parsed CVSS 3.1HIGH 7.5
- TI-2021-06275 DNS proxy and possible amplification attack CVSS 3.1HIGH 7.5
- TI-2016-05847 Cross-site request forgery in Apache Wicket CVSS 3.0HIGH 8.8
Sources
- CVE-2024-53299 · CVE Program
- CVE-2024-53299 · NVD
- FIRST EPSS
- GHSA-9cxr-76pm-j3wf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences