composio >=0.5.40 is vulnerable to Command Execution in composio_openai, composio_claude…
Priority LOW 29CWE-77Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
composio >=0.5.40 is vulnerable to Command Execution in composio_openai, composio_claude, and composio_julep via the handle_tool_calls function.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00605 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed composio-claude (PyPI): 0.6.9composio-openai (PyPI): 0.6.9+1 more product
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | composio-claude (PyPI) | 0.5.40 to before 0.6.9 | 0.6.9 | Patch available | GHSA-8h93-28hg-fj84 |
| — | composio-openai (PyPI) | 0.5.40 to before 0.6.9 | 0.6.9 | Patch available | GHSA-8h93-28hg-fj84 |
| — | composio-julep (PyPI) | 0.5.40 to before 0.6.9 | 0.6.9 | Patch available | GHSA-8h93-28hg-fj84 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- composio-claude (PyPI) Vendor— Affected 0.5.40 to before 0.6.9 Fixed in 0.6.9 Patch available GHSA-8h93-28hg-fj84
- composio-openai (PyPI) Vendor— Affected 0.5.40 to before 0.6.9 Fixed in 0.6.9 Patch available GHSA-8h93-28hg-fj84
- composio-julep (PyPI) Vendor— Affected 0.5.40 to before 0.6.9 Fixed in 0.6.9 Patch available GHSA-8h93-28hg-fj84
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:composio:composio:*:*:*:*:*:*:*:* | 0.5.40 | Vulnerable | composiohq |
- cpe:2.3:a:composio:composio:*:*:*:*:*:*:*:* Versions 0.5.40 Vulnerable ·composiohq
Remediation
- Fix · GHSA-8h93-28hg-fj84 composio-claude (PyPI) Fixed in 0.6.9 Advisory →
- Fix · GHSA-8h93-28hg-fj84 composio-openai (PyPI) Fixed in 0.6.9 Advisory →
- Fix · GHSA-8h93-28hg-fj84 composio-julep (PyPI) Fixed in 0.6.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-53526
- 2026-10-03 Alias added: GHSA-8h93-28hg-fj84
References
Other 6
- https://github.com/ComposioHQ/composio/blob/11ee7470aa6543097ee30bb036af8e9726dc7a85/python/plugins/openai/composio_openai/toolset.py#L184
- https://github.com/ComposioHQ/composio/blob/11ee7470aa6543097ee30bb036af8e9726dc7a85/python/plugins/claude/composio_claude/toolset.py#L156
- https://github.com/ComposioHQ/composio/blob/11ee7470aa6543097ee30bb036af8e9726dc7a85/python/plugins/julep/composio_julep/toolset.py#L21
- https://github.com/ComposioHQ/composio/pull/1107
- https://github.com/ComposioHQ/composio/commit/f496f7fa776335ae7825cad2991c9b38923271fc
- https://github.com/ComposioHQ/composio
More composiohq Composio vulnerabilities
- TI-2024-08314 Authentication Bypass in composiohq/composio CVSS 3.0CRITICAL 9.8
- TI-2024-08318 Unrestricted File Write and Read in composiohq/composio CVSS 3.1CRITICAL 9.8
- TI-2024-08313 Unsafe eval usage in composiohq/composio CVSS 3.1CRITICAL 9.8
- TI-2025-35340 Directory Traversal vulnerability in ComposioHQ v.0.7.20 allows a remote attacker to… CVSS 3.1HIGH 7.5
- TI-2024-08315 SSRF in composiohq/composio CVSS 3.1HIGH 7.5
- TI-2024-08312 SSRF in composiohq/composio CVSS 3.1HIGH 7.5
Sources
- CVE-2024-53526 · CVE Program
- CVE-2024-53526 · NVD
- FIRST EPSS
- GHSA-8h93-28hg-fj84 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences