Server-side request forgery in Backstage Scaffolder plugin
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-918 and the CVSS impact.
Summary
The Backstage Scaffolder plugin Houses types and utilities for building scaffolder-related modules. A vulnerability is identified in Backstage Scaffolder template functionality where Server-Side Template Injection (SSTI) can be exploited to perform Git config injection. The vulnerability allows an attacker to capture privileged git tokens used by the Backstage Scaffolder plugin. With these tokens, unauthorized access to sensitive resources in git can be achieved. The impact is considered medium severity as the Backstage Threat Model recommends restricting access to adding and editing templates in the Backstage Catalog plugin. The issue has been resolved in versions `v0.4.12`, `v0.5.1` and `v0.6.1` of the `@backstage/plugin-scaffolder-node` package. Users are encouraged to upgrade to this version to mitigate the vulnerability. Users are advised to upgrade. Users unable to upgrade may ensure that templates do not change git config.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| backstage | backstage | before 0.4.12; = 0.5.0; = 0.6.0 | 0.4.12 | Patch available | CNA |
| — | @backstage/plugin-scaffolder-node (npm) | before 0.4.12 | 0.4.12 | Patch available | GHSA-qmc2-jpr5-7rg9 |
| — | @backstage/plugin-scaffolder-node (npm) | 0.5.0 to before 0.5.1 | 0.5.1 | Patch available | GHSA-qmc2-jpr5-7rg9 |
| — | @backstage/plugin-scaffolder-node (npm) | 0.6.0 to before 0.6.1 | 0.6.1 | Patch available | GHSA-qmc2-jpr5-7rg9 |
- backstage Vendorbackstage Affected before 0.4.12; = 0.5.0; = 0.6.0 Fixed in 0.4.12 Patch available CNA
- @backstage/plugin-scaffolder-node (npm) Vendor— Affected before 0.4.12 Fixed in 0.4.12 Patch available GHSA-qmc2-jpr5-7rg9
- @backstage/plugin-scaffolder-node (npm) Vendor— Affected 0.5.0 to before 0.5.1 Fixed in 0.5.1 Patch available GHSA-qmc2-jpr5-7rg9
- @backstage/plugin-scaffolder-node (npm) Vendor— Affected 0.6.0 to before 0.6.1 Fixed in 0.6.1 Patch available GHSA-qmc2-jpr5-7rg9
Remediation
- Fix · CNA backstage (backstage) Fixed in 0.4.12
- Fix · GHSA-qmc2-jpr5-7rg9 @backstage/plugin-scaffolder-node (npm) Fixed in 0.4.12 Advisory →
- Fix · GHSA-qmc2-jpr5-7rg9 @backstage/plugin-scaffolder-node (npm) Fixed in 0.5.1 Advisory →
- Fix · GHSA-qmc2-jpr5-7rg9 @backstage/plugin-scaffolder-node (npm) Fixed in 0.6.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-53983
- 2026-10-03 Alias added: GHSA-qmc2-jpr5-7rg9
References
More backstage vulnerabilities
- TI-2026-33119 Malware in 42 @tanstack/* packages exfiltrates cloud credentials, GitHub tokens, and SSH keys KEVCVSS 3.1CRITICAL 9.6
- TI-2018-10499 Integer overflow in backstage kernel KEVCVSS 3.0HIGH 7.8
- TI-2024-08998 Remote Code Execution in kedro-org/kedro CVSS 3.0CRITICAL 9.8
- TI-2023-12294 Dragonfly2 vulnerable to hard coded cyptographic key CVSS 3.1CRITICAL 9.8
- TI-2021-12074 Authentication vulnerability in MOSN v.0.23.0 allows attacker to escalate privileges via… CVSS 3.1CRITICAL 9.8
- TI-2019-04061 runc through 1.0-rc6, as used in Docker before 18.09.2 and other products, allows… CVSS 3.1HIGH 8.6
Sources
- CVE-2024-53983 · CVE Program
- CVE-2024-53983 · NVD
- FIRST EPSS
- GHSA-qmc2-jpr5-7rg9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences