Possible Content Security Policy bypass in Action Dispatch
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Action Pack is a framework for handling and responding to web requests. There is a possible Cross Site Scripting (XSS) vulnerability in the `content_security_policy` helper starting in version 5.2.0 of Action Pack and prior to versions 7.0.8.7, 7.1.5.1, 7.2.2.1, and 8.0.0.1. Applications which set Content-Security-Policy (CSP) headers dynamically from untrusted user input may be vulnerable to carefully crafted inputs being able to inject new directives into the CSP. This could lead to a bypass of the CSP and its protection against XSS and other attacks. Versions 7.0.8.7, 7.1.5.1, 7.2.2.1, and 8.0.0.1 contain a fix. As a workaround, applications can avoid setting CSP headers dynamically from untrusted input, or can validate/sanitize that input.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Rails | rails | 5.2.0 to before 7.0.8.7; 7.1.0 to before 7.1.5.1; 7.2.0 to before 7.2.2.1; 8.0.0 to before 8.0.0.1 | 7.0.8.7, 7.1.5.1, 7.2.2.1, 8.0.0.1 | Patch available | CNA |
| — | actionpack (RubyGems) | 5.2.0 to before 7.0.8.7 | 7.0.8.7 | Patch available | GHSA-vfm5-rmrh-j26v |
| — | actionpack (RubyGems) | 7.1.0 to before 7.1.5.1 | 7.1.5.1 | Patch available | GHSA-vfm5-rmrh-j26v |
| — | actionpack (RubyGems) | 7.2.0 to before 7.2.2.1 | 7.2.2.1 | Patch available | GHSA-vfm5-rmrh-j26v |
| — | actionpack (RubyGems) | 8.0.0 to before 8.0.0.1 | 8.0.0.1 | Patch available | GHSA-vfm5-rmrh-j26v |
- rails VendorRails Affected 5.2.0 to before 7.0.8.7; 7.1.0 to before 7.1.5.1; 7.2.0 to before 7.2.2.1; 8.0.0 to before 8.0.0.1 Fixed in 7.0.8.7, 7.1.5.1, 7.2.2.1, 8.0.0.1 Patch available CNA
- actionpack (RubyGems) Vendor— Affected 5.2.0 to before 7.0.8.7 Fixed in 7.0.8.7 Patch available GHSA-vfm5-rmrh-j26v
- actionpack (RubyGems) Vendor— Affected 7.1.0 to before 7.1.5.1 Fixed in 7.1.5.1 Patch available GHSA-vfm5-rmrh-j26v
- actionpack (RubyGems) Vendor— Affected 7.2.0 to before 7.2.2.1 Fixed in 7.2.2.1 Patch available GHSA-vfm5-rmrh-j26v
- actionpack (RubyGems) Vendor— Affected 8.0.0 to before 8.0.0.1 Fixed in 8.0.0.1 Patch available GHSA-vfm5-rmrh-j26v
Remediation
- Fix · CNA rails (rails) Fixed in 7.0.8.7, 7.1.5.1, 7.2.2.1, 8.0.0.1
- Fix · GHSA-vfm5-rmrh-j26v actionpack (RubyGems) Fixed in 7.0.8.7 Advisory →
- Fix · GHSA-vfm5-rmrh-j26v actionpack (RubyGems) Fixed in 7.1.5.1 Advisory →
- Fix · GHSA-vfm5-rmrh-j26v actionpack (RubyGems) Fixed in 7.2.2.1 Advisory →
- Fix · GHSA-vfm5-rmrh-j26v actionpack (RubyGems) Fixed in 8.0.0.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat 3scale API Management Platform 2 | Affected | No fix yet: Fix deferred |
| Red Hat Satellite 6 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2024-54133
- 2026-10-03 Alias added: GHSA-vfm5-rmrh-j26v
References
Other 8
- https://github.com/rails/rails/security/advisories/GHSA-vfm5-rmrh-j26v
- https://github.com/rails/rails/commit/2e3f41e4538b9ca1044357f6644f037bbb7c6c49
- https://github.com/rails/rails/commit/3da2479cfe1e00177114b17e496213c40d286b3a
- https://github.com/rails/rails/commit/5558e72f22fc69c1c407b31ac5fb3b4ce087b542
- https://github.com/rails/rails/commit/cb16a3bb515b5d769f73926d9757270ace691f1d
- https://github.com/rails/rails
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/actionpack/CVE-2024-54133.yml
- https://security.netapp.com/advisory/ntap-20250306-0010
More Rails vulnerabilities
- TI-2014-00124 Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the… KEVCVSS 3.1HIGH 7.5
- TI-2019-03828 Path traversal in Rails https://github.com/rails/rails KEVCVSS 3.1HIGH 7.5
- TI-2016-00672 Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.1, 4.0.x… KEVCVSS 3.1HIGH 7.5
- TI-2019-03830 Command injection in Rails https://github.com/rails/rails CVSS 3.1CRITICAL 9.8
- TI-2026-47043 Action Pack: Possible arbitrary file read and remote code execution in Active Storage variant processing CVSS 4.0CRITICAL 9.5
- TI-2025-18040 Command injection in Rails activestorage CVSS 4.0CRITICAL 9.2
Sources
- CVE-2024-54133 · CVE Program
- CVE-2024-54133 · NVD
- FIRST EPSS
- GHSA-vfm5-rmrh-j26v · GitHub Advisory Database · CC BY 4.0
- CVE-2024-54133 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences