KVM: x86: Play nice with protected guests in complete_hypercall_exit()
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 4 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: KVM: x86: Play nice with protected guests in complete_hypercall_exit() Use is_64_bit_hypercall() instead of is_64_bit_mode() to detect a 64-bit hypercall when completing said hypercall. For guests with protected state, e.g. SEV-ES and SEV-SNP, KVM must assume the hypercall was made in 64-bit mode as the vCPU state needed to detect 64-bit mode is unavailable. Hacking the sev_smoke_test selftest to generate a KVM_HC_MAP_GPA_RANGE hypercall via VMGEXIT trips the WARN: ------------[ cut here ]------------ WARNING: CPU: 273 PID: 326626 at arch/x86/kvm/x86.h:180 complete_hypercall_exit+0x44/0xe0 [kvm] Modules linked in: kvm_amd kvm ... [last unloaded: kvm] CPU: 273 UID: 0 PID: 326626 Comm: sev_smoke_test Not tainted 6.12.0-smp--392e932fa0f3-feat #470 Hardware name: Google Astoria/astoria, BIOS 0.20240617.0-0 06/17/2024 RIP: 0010:complete_hypercall_exit+0x44/0xe0 [kvm] Call Trace: <TASK> kvm_arch_vcpu_ioctl_run+0x2400/0x2720 [kvm] kvm_vcpu_ioctl+0x54f/0x630 [kvm] __se_sys_ioctl+0x6b/0xc0 do_syscall_64+0x83/0x160 entry_SYSCALL_64_after_hwframe+0x76/0x7e </TASK> ---[ end trace 0000000000000000 ]---
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.15.5 to before 5.15.176 | 5.15.176 | Patch available | CNA |
| Linux | Linux | 5.16 and later | 5.15.176, 6.1.122, 6.6.68, 6.12.7, 6.13 | Patch available | CNA |
- Linux VendorLinux Affected 5.15.5 to before 5.15.176 Fixed in 5.15.176 Patch available CNA
- Linux VendorLinux Affected 5.16 and later Fixed in 5.15.176, 6.1.122, 6.6.68, 6.12.7, 6.13 Patch available CNA
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.15.5 to before 5.15.176; 5.16.1 to before 6.1.122; 6.2 to before 6.6.68; 6.7 to before 6.12.7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.16:-:*:*:*:*:*:* | 5.16 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.16:rc2:*:*:*:*:*:* | 5.16 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.16:rc3:*:*:*:*:*:* | 5.16 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.16:rc4:*:*:*:*:*:* | 5.16 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.16:rc5:*:*:*:*:*:* | 5.16 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.16:rc6:*:*:*:*:*:* | 5.16 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.16:rc7:*:*:*:*:*:* | 5.16 rc7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.16:rc8:*:*:*:*:*:* | 5.16 rc8 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.13:rc1:*:*:*:*:*:* | 6.13 rc1 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.15.5 to before 5.15.176; 5.16.1 to before 6.1.122; 6.2 to before 6.6.68; 6.7 to before 6.12.7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.16:-:*:*:*:*:*:* Versions 5.16 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.16:rc2:*:*:*:*:*:* Versions 5.16 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.16:rc3:*:*:*:*:*:* Versions 5.16 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.16:rc4:*:*:*:*:*:* Versions 5.16 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.16:rc5:*:*:*:*:*:* Versions 5.16 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.16:rc6:*:*:*:*:*:* Versions 5.16 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.16:rc7:*:*:*:*:*:* Versions 5.16 rc7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.16:rc8:*:*:*:*:*:* Versions 5.16 rc8 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.13:rc1:*:*:*:*:*:* Versions 6.13 rc1 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.15.176
- Fix · CNA Linux (Linux) Fixed in 5.15.176, 6.1.122, 6.6.68, 6.12.7, 6.13
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2024-55881
- 2026-10-03 Alias added: GHSA-h4p6-vxwp-4w5q
- 2026-11-05 CISA SSVC decision points changed
References
Patch 5
- https://git.kernel.org/stable/c/0840d360a8909c722fb62459f42836afe32ededb
- https://git.kernel.org/stable/c/7ed4db315094963de0678a8adfd43c46471b9349
- https://git.kernel.org/stable/c/3d2634ec0d1dbe8f4b511cf5261f327c6a76f4b6
- https://git.kernel.org/stable/c/22b5c2acd65dbe949032f619d4758a35a82fffc3
- https://git.kernel.org/stable/c/9b42d1e8e4fe9dc631162c04caa69b0d1860b0f0
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-55881 · CVE Program
- CVE-2024-55881 · NVD
- FIRST EPSS
- GHSA-h4p6-vxwp-4w5q · GitHub Advisory Database · CC BY 4.0
- CVE-2024-55881 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences