Read the docs
TI-2024-36952 Aliases CVE-2024-55886

OpenTelemetry Logs source may lack authentication with some custom plugins

Priority LOW 30CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
High
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-287.

Summary

OpenSearch Data Prepper is a component of the OpenSearch project that accepts, filters, transforms, enriches, and routes data at scale. A vulnerability exists in the OpenTelemetry Logs source in Data Prepper starting inversion 2.1.0 and prior to version 2.10.2 where some custom authentication plugins will not perform authentication. This allows unauthorized users to ingest OpenTelemetry Logs data under certain conditions. This vulnerability does not affect the built-in `http_basic` authentication provider in Data Prepper. Pipelines which use the `http_basic` authentication provider continue to require authentication. The vulnerability exists only for custom implementations of Data Prepper’s `GrpcAuthenticationProvider` authentication plugin which implement the `getHttpAuthenticationService()` method instead of `getAuthenticationInterceptor()`. Data Prepper 2.10.2 contains a fix for this issue. For those unable to upgrade, one may use the built-in `http_basic` authentication provider in Data Prepper and/or add an authentication proxy in front of one's Data Prepper instances running the OpenTelemetry Logs source.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00325 25th percentileScored 2026-11-07
Fix Fixed data-prepper (opensearch-project): 2.10.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
AWSdata-prepper2.1.0 to before 2.10.22.10.2Patch availableCNA
  • data-prepper VendorAWS Affected 2.1.0 to before 2.10.2 Fixed in 2.10.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:amazon:opensearch_data_prepper:*:*:*:*:*:*:*:*2.1.0 to before 2.10.2VulnerableAWS
  • cpe:2.3:a:amazon:opensearch_data_prepper:*:*:*:*:*:*:*:* Versions 2.1.0 to before 2.10.2 Vulnerable ·AWS

Remediation

  • Fix · CNA data-prepper (opensearch-project) Fixed in 2.10.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-55886

References

  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2025-38639 OpenSearch Data Prepper plugins trusts all SSL certificates by default CVSS 3.1HIGH 7.4

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences