Apache EventMesh: raft Hessian Deserialization Vulnerability allowing remote code execution
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
CWE-502 Deserialization of Untrusted Data at the eventmesh-meta-raft plugin module in Apache EventMesh master branch without release version on windows\linux\mac os e.g. platforms allows attackers to send controlled message and remote code execute via hessian deserialization rpc protocol. Users can use the code under the master branch in project repo or version 1.11.0 to fix this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache EventMesh | 1.10.1 to before 1.11.0 | 1.11.0 | Patch available | CNA |
| — | org.apache.eventmesh:eventmesh-meta-raft (Maven) | 1.10.1 to before 1.11.0 | 1.11.0 | Patch available | GHSA-ffvr-gmp3-xx43 |
- Apache EventMesh VendorApache Affected 1.10.1 to before 1.11.0 Fixed in 1.11.0 Patch available CNA
- org.apache.eventmesh:eventmesh-meta-raft (Maven) Vendor— Affected 1.10.1 to before 1.11.0 Fixed in 1.11.0 Patch available GHSA-ffvr-gmp3-xx43
Remediation
- Fix · CNA Apache EventMesh (Apache Software Foundation) Fixed in 1.11.0
- Fix · GHSA-ffvr-gmp3-xx43 org.apache.eventmesh:eventmesh-meta-raft (Maven) Fixed in 1.11.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-56180
- 2026-10-03 Alias added: GHSA-ffvr-gmp3-xx43
References
More Apache Eventmesh vulnerabilities
- TI-2024-26839 Apache EventMesh Runtime: SSRF CVSS 3.1MEDIUM 6.3
Sources
- CVE-2024-56180 · CVE Program
- CVE-2024-56180 · NVD
- FIRST EPSS
- GHSA-ffvr-gmp3-xx43 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences