Read the docs
TI-2024-37331 Aliases CVE-2024-56374GHSA-qcgg-j2x8-h9g8

Resource allocation without limits in djangoproject Django

Priority MEDIUM 41CWE-770Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 7 fixed, 2 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-770.

Summary

An issue was discovered in Django 5.1 before 5.1.5, 5.0 before 5.0.11, and 4.2 before 4.2.18. Lack of upper-bound limit enforcement in strings passed when performing IPv6 validation could lead to a potential denial-of-service attack. The undocumented and private functions clean_ipv6_address and is_valid_ipv6_address are vulnerable, as is the django.forms.GenericIPAddressField form field. (The django.db.models.GenericIPAddressField model field is not affected.)

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01277 70th percentileScored 2026-11-07
Fix Partial Django (djangoproject): 4.2.18, 5.0.11, 5.1.5Django (PyPI): 5.1.5, 5.0.11, 4.2.18+1 more productRed Hat: 6 advisoriesRed Hat: 7 fixed, 2 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
djangoprojectDjango4.2 to before 4.2.18; 5.0 to before 5.0.11; 5.1 to before 5.1.54.2.18, 5.0.11, 5.1.5Patch availableCNA
—Django (PyPI)5.1 to before 5.1.55.1.5Patch availableGHSA-qcgg-j2x8-h9g8
—Django (PyPI)5.0 to before 5.0.115.0.11Patch availableGHSA-qcgg-j2x8-h9g8
—Django (PyPI)4.2 to before 4.2.184.2.18Patch availableGHSA-qcgg-j2x8-h9g8
—django (PyPI)5.1 to before 5.1.55.1.5Patch availableGHSA-qcgg-j2x8-h9g8
—django (PyPI)5.0 to before 5.0.115.0.11Patch availableGHSA-qcgg-j2x8-h9g8
—django (PyPI)4.2 to before 4.2.184.2.18Patch availableGHSA-qcgg-j2x8-h9g8
  • Django Vendordjangoproject Affected 4.2 to before 4.2.18; 5.0 to before 5.0.11; 5.1 to before 5.1.5 Fixed in 4.2.18, 5.0.11, 5.1.5 Patch available CNA
  • Django (PyPI) Vendor— Affected 5.1 to before 5.1.5 Fixed in 5.1.5 Patch available GHSA-qcgg-j2x8-h9g8
  • Django (PyPI) Vendor— Affected 5.0 to before 5.0.11 Fixed in 5.0.11 Patch available GHSA-qcgg-j2x8-h9g8
  • Django (PyPI) Vendor— Affected 4.2 to before 4.2.18 Fixed in 4.2.18 Patch available GHSA-qcgg-j2x8-h9g8
  • django (PyPI) Vendor— Affected 5.1 to before 5.1.5 Fixed in 5.1.5 Patch available GHSA-qcgg-j2x8-h9g8
  • django (PyPI) Vendor— Affected 5.0 to before 5.0.11 Fixed in 5.0.11 Patch available GHSA-qcgg-j2x8-h9g8
  • django (PyPI) Vendor— Affected 4.2 to before 4.2.18 Fixed in 4.2.18 Patch available GHSA-qcgg-j2x8-h9g8

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:*4.2 to before 4.2.18; 5.0 to before 5.0.11; 5.1 to before 5.1.5Vulnerabledjangoproject
cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*11.0VulnerableDebian
  • cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions 4.2 to before 4.2.18; 5.0 to before 5.0.11; 5.1 to before 5.1.5 Vulnerable ·djangoproject
  • cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian

Remediation

  • Fix · CNA Django (djangoproject) Fixed in 4.2.18, 5.0.11, 5.1.5
  • Fix · GHSA-qcgg-j2x8-h9g8 Django (PyPI) Fixed in 5.1.5 Advisory →
  • Fix · GHSA-qcgg-j2x8-h9g8 Django (PyPI) Fixed in 5.0.11 Advisory →
  • Fix · GHSA-qcgg-j2x8-h9g8 Django (PyPI) Fixed in 4.2.18 Advisory →
  • Fix · GHSA-qcgg-j2x8-h9g8 django (PyPI) Fixed in 5.1.5 Advisory →
  • Fix · GHSA-qcgg-j2x8-h9g8 django (PyPI) Fixed in 5.0.11 Advisory →
  • Fix · GHSA-qcgg-j2x8-h9g8 django (PyPI) Fixed in 4.2.18 Advisory →

Red Hat 6 advisories

  • RHSA-2025:4576 Released 2025-05-06 · Red Hat rating Important
    Satellite 6.17.0 release
    • Red Hat Satellite 6.17 for RHEL 9 python-django-4.2.19-1.el9pc, python-jinja2-3.1.5-1.el9pc, python3.11-django-4.2.19-1.el9pc +3
  • RHSA-2025:2399 Released 2025-03-05 · Red Hat rating Moderate
    Satellite 6.16.3 Async Update
    • Red Hat Satellite 6.16 for RHEL 8 candlepin-4.4.21-1.el8sat, candlepin-selinux-4.4.21-1.el8sat, foreman-3.12.0.6-1.el8sat +42
    • Red Hat Satellite 6.16 for RHEL 9 candlepin-4.4.21-1.el9sat, candlepin-selinux-4.4.21-1.el9sat, foreman-3.12.0.6-1.el9sat +42
  • RHSA-2025:1249 Released 2025-02-10 · Red Hat rating Important
    updated discovery container images
    • Discovery 1 for RHEL 9 discovery/discovery-server-rhel9, discovery/discovery-ui-rhel9
Show 3 more Red Hat advisories
  • RHSA-2025:0782 Released 2025-01-28 · Red Hat rating Moderate
    Red Hat Ansible Automation Platform 2.5 Container Release Update
    • Red Hat Ansible Automation Platform 2.5 for RHEL 8 ansible-automation-platform-25/lightspeed-rhel8
  • RHSA-2025:0777 Released 2025-01-28 · Red Hat rating Important
    Red Hat Ansible Automation Platform 2.5 Product Security and Bug Fix Update
    • Red Hat Ansible Automation Platform 2.5 for RHEL 8 automation-controller-venv-tower-4.6.7-1.el8ap, python3.11-django-4.2.18-1.el8ap, python3.11-jinja2-3.1.5-1.el8ap
    • Red Hat Ansible Automation Platform 2.5 for RHEL 9 automation-controller-venv-tower-4.6.7-1.el9ap, python3.11-django-4.2.18-1.el9ap, python3.11-jinja2-3.1.5-1.el9ap
  • RHSA-2025:0722 Released 2025-01-27 · Red Hat rating Important
    Red Hat Ansible Automation Platform 2.4 Container Release Update
    • Red Hat Ansible Automation Platform 2.4 for RHEL 8 ansible-automation-platform-24/lightspeed-rhel8-operator

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Ansible Automation Platform 2AffectedNo fix yet
Red Hat Update Infrastructure 4 for Cloud ProvidersAffectedNo fix planned: Will not fix
Discovery 1 for RHEL 9Fixed RHSA-2025:1249
Red Hat Ansible Automation Platform 2.4 for RHEL 8Fixed RHSA-2025:0722
Red Hat Ansible Automation Platform 2.5 for RHEL 8Fixed RHSA-2025:0777, RHSA-2025:0782
Red Hat Ansible Automation Platform 2.5 for RHEL 9Fixed RHSA-2025:0777
Red Hat Satellite 6.16 for RHEL 8Fixed RHSA-2025:2399
Red Hat Satellite 6.16 for RHEL 9Fixed RHSA-2025:2399
Red Hat Satellite 6.17 for RHEL 9Fixed RHSA-2025:4576
Not affected: 14 products
  • Red Hat Ansible Automation Platform 1.2
  • Red Hat Ansible Automation Platform 2
  • Red Hat Ansible Automation Platform 2.4 for RHEL 8
  • Red Hat Ansible Automation Platform 2.4 for RHEL 9
  • Red Hat Ansible Automation Platform 2.5 for RHEL 8
  • Red Hat Ansible Automation Platform 2.5 for RHEL 9
  • Red Hat Certification for Red Hat Enterprise Linux 7
  • Red Hat OpenStack Platform 16.2
  • Red Hat OpenStack Platform 17.1
  • Red Hat OpenStack Platform 18.0
  • Red Hat Satellite 6.16 for RHEL 8
  • Red Hat Satellite 6.16 for RHEL 9
  • Red Hat Satellite 6.17 for RHEL 9
  • Red Hat Storage 3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-56374
  2. 2026-10-03 Alias added: GHSA-qcgg-j2x8-h9g8

References

  • TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
  • TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
  • TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
  • TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
  • TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
  • TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
See all 156 →

Sources