netdevsim: prevent bad user input in nsim_dev_health_break_write()
Priority LOW 24CWE-1284Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and Red Hat.
Summary
In the Linux kernel, the following vulnerability has been resolved: netdevsim: prevent bad user input in nsim_dev_health_break_write() If either a zero count or a large one is provided, kernel can crash.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00208 10th percentileScored 2026-11-07
Fix Partial Linux (Linux): 5.10.233, 5.15.176, 6.1.122 +3Red Hat: 2 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.5 and later | 5.10.233, 5.15.176, 6.1.122, 6.6.68, 6.12.7, 6.13 | Patch available | CNA |
- Linux VendorLinux Affected 5.5 and later Fixed in 5.10.233, 5.15.176, 6.1.122, 6.6.68, 6.12.7, 6.13 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.5 to before 5.10.233; 5.11 to before 5.15.176; 5.16 to before 6.1.122; 6.2 to before 6.6.68; 6.7 to before 6.12.7 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.13:rc1:*:*:*:*:*:* | 6.13 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.13:rc2:*:*:*:*:*:* | 6.13 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.13:rc3:*:*:*:*:*:* | 6.13 rc3 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.5 to before 5.10.233; 5.11 to before 5.15.176; 5.16 to before 6.1.122; 6.2 to before 6.6.68; 6.7 to before 6.12.7 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.13:rc1:*:*:*:*:*:* Versions 6.13 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.13:rc2:*:*:*:*:*:* Versions 6.13 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.13:rc3:*:*:*:*:*:* Versions 6.13 rc3 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.10.233, 5.15.176, 6.1.122, 6.6.68, 6.12.7, 6.13
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 9 | Affected | No fix planned: Will not fix |
Not affected: 2 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2024-56716
- 2026-10-03 Alias added: GHSA-8896-pxp4-28pj
References
Patch 6
- https://git.kernel.org/stable/c/81bdfcd6e6a998e219c9dd49ec7291c2e0594bbc
- https://git.kernel.org/stable/c/b3a6daaf7cfb2de37b89fd7a5a2ad4ea9aa3e181
- https://git.kernel.org/stable/c/d10321be26ff9e9e912697e9e8448099654ff561
- https://git.kernel.org/stable/c/470c5ecbac2f19b1cdee2a6ce8d5650c3295c94b
- https://git.kernel.org/stable/c/8e9ef6bdf71bf25f4735e0230ce1919de8985835
- https://git.kernel.org/stable/c/ee76746387f6233bdfa93d7406990f923641568f
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-56716 · CVE Program
- CVE-2024-56716 · NVD
- FIRST EPSS
- GHSA-8896-pxp4-28pj · GitHub Advisory Database · CC BY 4.0
- CVE-2024-56716 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences