drm/sti: avoid potential dereference of error pointers in sti_gdp_atomic_check
Priority LOW 24CWE-754Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: drm/sti: avoid potential dereference of error pointers in sti_gdp_atomic_check The return value of drm_atomic_get_crtc_state() needs to be checked. To avoid use of error pointer 'crtc_state' in case of the failure.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00207 10th percentileScored 2026-11-07
Fix Fixed Linux (Linux): 5.15.174, 6.1.120, 6.6.64 +2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 4.6 and later | 5.15.174, 6.1.120, 6.6.64, 6.12.4, 6.13 | Patch available | CNA |
- Linux VendorLinux Affected 4.6 and later Fixed in 5.15.174, 6.1.120, 6.6.64, 6.12.4, 6.13 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 4.6 to before 5.15.174; 5.16 to before 6.1.120; 6.2 to before 6.6.64; 6.7 to before 6.12.4 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 4.6 to before 5.15.174; 5.16 to before 6.1.120; 6.2 to before 6.6.64; 6.7 to before 6.12.4 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.15.174, 6.1.120, 6.6.64, 6.12.4, 6.13
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-56777
- 2026-10-03 Alias added: GHSA-w4pw-p565-4p8w
References
Patch 5
- https://git.kernel.org/stable/c/f5804567cf9605d6e5ec46c0bb786f7d50f18c13
- https://git.kernel.org/stable/c/b79612ed6bc1a184c45427105c851b5b2d4342ca
- https://git.kernel.org/stable/c/997b64c3f4c1827c5cfda8ae7f5d13f78d28b541
- https://git.kernel.org/stable/c/3cf2e7c448e246f7e700c7aa47450d1e27579559
- https://git.kernel.org/stable/c/e965e771b069421c233d674c3c8cd8c7f7245f42
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-56777 · CVE Program
- CVE-2024-56777 · NVD
- FIRST EPSS
- GHSA-w4pw-p565-4p8w · GitHub Advisory Database · CC BY 4.0
- CVE-2024-56777 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences