Cross Site Scripting vulnerability in nbubna store v.2.14.2 and before allows a remote…
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross Site Scripting vulnerability in nbubna store v.2.14.2 and before allows a remote attacker to execute arbitrary code via the store.deep.js component
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00363 30th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed store2 (npm): 2.14.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | store2 (npm) | before 2.14.4 | 2.14.4 | Patch available | GHSA-w5hq-hm5m-4548 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- store2 (npm) Vendor— Affected before 2.14.4 Fixed in 2.14.4 Patch available GHSA-w5hq-hm5m-4548
Remediation
- Fix · GHSA-w5hq-hm5m-4548 store2 (npm) Fixed in 2.14.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-57556
- 2026-10-03 Alias added: GHSA-w5hq-hm5m-4548
References
Sources
- CVE-2024-57556 · CVE Program
- CVE-2024-57556 · NVD
- FIRST EPSS
- GHSA-w5hq-hm5m-4548 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences