KEYS: trusted: dcp: fix improper sg use with CONFIG_VMAP_STACK=y
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: KEYS: trusted: dcp: fix improper sg use with CONFIG_VMAP_STACK=y With vmalloc stack addresses enabled (CONFIG_VMAP_STACK=y) DCP trusted keys can crash during en- and decryption of the blob encryption key via the DCP crypto driver. This is caused by improperly using sg_init_one() with vmalloc'd stack buffers (plain_key_blob). Fix this by always using kmalloc() for buffers we give to the DCP crypto driver.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 6.10.7 to before 6.11 | 6.11 | Patch available | CNA |
| Linux | Linux | 6.11 and later | 6.12.14, 6.13.3, 6.14 | Patch available | CNA |
- Linux VendorLinux Affected 6.10.7 to before 6.11 Fixed in 6.11 Patch available CNA
- Linux VendorLinux Affected 6.11 and later Fixed in 6.12.14, 6.13.3, 6.14 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 6.10.7 to before 6.11; 6.11.1 to before 6.12.14; 6.13 to before 6.13.3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:-:*:*:*:*:*:* | 6.11 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc4:*:*:*:*:*:* | 6.11 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc5:*:*:*:*:*:* | 6.11 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc6:*:*:*:*:*:* | 6.11 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.11:rc7:*:*:*:*:*:* | 6.11 rc7 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 6.10.7 to before 6.11; 6.11.1 to before 6.12.14; 6.13 to before 6.13.3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:-:*:*:*:*:*:* Versions 6.11 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc4:*:*:*:*:*:* Versions 6.11 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc5:*:*:*:*:*:* Versions 6.11 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc6:*:*:*:*:*:* Versions 6.11 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.11:rc7:*:*:*:*:*:* Versions 6.11 rc7 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 6.11
- Fix · CNA Linux (Linux) Fixed in 6.12.14, 6.13.3, 6.14
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-58008
- 2026-10-03 Alias added: GHSA-c982-mg4h-7c8x
- 2026-11-07 Affected versions changed · Red Hat
References
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2024-58008 · CVE Program
- CVE-2024-58008 · NVD
- FIRST EPSS
- GHSA-c982-mg4h-7c8x · GitHub Advisory Database · CC BY 4.0
- CVE-2024-58008 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences