Rancher affected by unauthenticated Denial of Service
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · Low · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-770.
Summary
A vulnerability has been identified within Rancher Manager in which it did not enforce request body size limits on certain public (unauthenticated) and authenticated API endpoints. This allows a malicious user to exploit this by sending excessively large payloads, which are fully loaded into memory during processing, leading to Denial of Service (DoS).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | rancher | 2.12.0 to before 2.12.1; 2.11.0 to before 2.11.5; 2.10.0 to before 2.10.9; 2.9.0 to before 2.9.11; before 0.0.0-20250813072957-aee95d4e2a41 | 2.12.1, 2.11.5, 2.10.9, 2.9.11, 0.0.0-20250813072957-aee95d4e2a41 | Patch available | CNA |
| — | github.com/rancher/rancher (Go) | 2.12.0 to before 2.12.1 | 2.12.1 | Patch available | GHSA-4h45-jpvh-6p5j |
| — | github.com/rancher/rancher (Go) | 2.11.0 to before 2.11.5 | 2.11.5 | Patch available | GHSA-4h45-jpvh-6p5j |
| — | github.com/rancher/rancher (Go) | 2.10.0 to before 2.10.9 | 2.10.9 | Patch available | GHSA-4h45-jpvh-6p5j |
| — | github.com/rancher/rancher (Go) | 2.9.0 to before 2.9.11 | 2.9.11 | Patch available | GHSA-4h45-jpvh-6p5j |
| — | github.com/rancher/rancher (Go) | before 0.0.0-20250813072957-aee95d4e2a41 | 0.0.0-20250813072957-aee95d4e2a41 | Patch available | GHSA-4h45-jpvh-6p5j |
- rancher VendorSUSE Affected 2.12.0 to before 2.12.1; 2.11.0 to before 2.11.5; 2.10.0 to before 2.10.9; 2.9.0 to before 2.9.11; before 0.0.0-20250813072957-aee95d4e2a41 Fixed in 2.12.1, 2.11.5, 2.10.9, 2.9.11, 0.0.0-20250813072957-aee95d4e2a41 Patch available CNA
- github.com/rancher/rancher (Go) Vendor— Affected 2.12.0 to before 2.12.1 Fixed in 2.12.1 Patch available GHSA-4h45-jpvh-6p5j
- github.com/rancher/rancher (Go) Vendor— Affected 2.11.0 to before 2.11.5 Fixed in 2.11.5 Patch available GHSA-4h45-jpvh-6p5j
- github.com/rancher/rancher (Go) Vendor— Affected 2.10.0 to before 2.10.9 Fixed in 2.10.9 Patch available GHSA-4h45-jpvh-6p5j
- github.com/rancher/rancher (Go) Vendor— Affected 2.9.0 to before 2.9.11 Fixed in 2.9.11 Patch available GHSA-4h45-jpvh-6p5j
- github.com/rancher/rancher (Go) Vendor— Affected before 0.0.0-20250813072957-aee95d4e2a41 Fixed in 0.0.0-20250813072957-aee95d4e2a41 Patch available GHSA-4h45-jpvh-6p5j
Remediation
- Fix · CNA rancher (SUSE) Fixed in 2.12.1, 2.11.5, 2.10.9, 2.9.11, 0.0.0-20250813072957-aee95d4e2a41
- Fix · GHSA-4h45-jpvh-6p5j github.com/rancher/rancher (Go) Fixed in 2.12.1 Advisory →
- Fix · GHSA-4h45-jpvh-6p5j github.com/rancher/rancher (Go) Fixed in 2.11.5 Advisory →
- Fix · GHSA-4h45-jpvh-6p5j github.com/rancher/rancher (Go) Fixed in 2.10.9 Advisory →
- Fix · GHSA-4h45-jpvh-6p5j github.com/rancher/rancher (Go) Fixed in 2.9.11 Advisory →
- Fix · GHSA-4h45-jpvh-6p5j github.com/rancher/rancher (Go) Fixed in 0.0.0-20250813072957-aee95d4e2a41 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-58259
- 2026-10-03 Alias added: GHSA-4h45-jpvh-6p5j
References
Other 8
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2024-58259
- https://github.com/rancher/rancher/security/advisories/GHSA-4h45-jpvh-6p5j
- https://github.com/rancher/rancher/commit/aee95d4e2a41ba2df6f88c9634d4fe1f42dee4d9
- https://github.com/rancher/rancher
- https://github.com/rancher/rancher/releases/tag/v2.10.9
- https://github.com/rancher/rancher/releases/tag/v2.11.5
- https://github.com/rancher/rancher/releases/tag/v2.12.1
- https://github.com/rancher/rancher/releases/tag/v2.9.11
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-58259 · CVE Program
- CVE-2024-58259 · NVD
- FIRST EPSS
- GHSA-4h45-jpvh-6p5j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences