SurrealDB before 2.0.4 Improper Authorization via SELECT Permissions
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-285.
Summary
SurrealDB versions before 2.0.4 fail to properly enforce field permissions during SELECT, UPDATE, and DELETE operations, allowing authorized users to access unauthorized field values through various query techniques. Attackers can exploit SELECT VALUE operations, field aliasing, function arguments, WHERE clause filtering, RETURN BEFORE clauses, and SET clause references to leak protected field contents despite lacking SELECT permissions.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| surrealdb | surrealdb | before 2.0.4 | 2.0.4 | Patch available | CNA |
| surrealdb | surrealdb | before 2.0.4 | 2.0.4 | Patch available | CNA |
| — | surrealdb (crates.io) | before 2.0.4 | 2.0.4 | Patch available | GHSA-9722-9j67-vjcr |
| — | surrealdb-core (crates.io) | before 2.0.4 | 2.0.4 | Patch available | GHSA-9722-9j67-vjcr |
- surrealdb Vendorsurrealdb Affected before 2.0.4 Fixed in 2.0.4 Patch available CNA
- surrealdb Vendorsurrealdb Affected before 2.0.4 Fixed in 2.0.4 Patch available CNA
- surrealdb (crates.io) Vendor— Affected before 2.0.4 Fixed in 2.0.4 Patch available GHSA-9722-9j67-vjcr
- surrealdb-core (crates.io) Vendor— Affected before 2.0.4 Fixed in 2.0.4 Patch available GHSA-9722-9j67-vjcr
Remediation
- Fix · CNA surrealdb (surrealdb) Fixed in 2.0.4
- Fix · CNA surrealdb (surrealdb) Fixed in 2.0.4
- Fix · GHSA-9722-9j67-vjcr surrealdb (crates.io) Fixed in 2.0.4 Advisory →
- Fix · GHSA-9722-9j67-vjcr surrealdb-core (crates.io) Fixed in 2.0.4 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
surrealdb 2.0.4
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2024-38445 SurrealDB before 2.0.4 Denial of Service via Parser ExceptionPriority LOW 32
Timeline
- 2026-10-02 Threatist record created from CVE-2024-58367
- 2026-10-03 Alias added: GHSA-9722-9j67-vjcr
References
Advisory 2
Other 12
- https://github.com/surrealdb/surrealdb/issues/2161
- https://github.com/surrealdb/surrealdb/issues/3924
- https://github.com/surrealdb/surrealdb/pull/4785
- https://github.com/surrealdb/surrealdb/pull/4800
- https://github.com/surrealdb/surrealdb/pull/4873
- https://github.com/surrealdb/surrealdb/commit/439ab99e15314ec5cf87047bf58246db646e3f8c
- https://github.com/surrealdb/surrealdb/commit/c382fa158dc84b329328606f663efe574f102a7d
- https://github.com/surrealdb/surrealdb/commit/e75e7736b3a028c4b6a4a4bdf00791d76f77e339
- https://github.com/surrealdb/surrealdb
- https://surrealdb.com/docs/surrealdb/security/summary#permissions
- https://surrealdb.com/docs/surrealql/statements/define/field#setting-permissions-on-fields
- https://surrealdb.com/docs/surrealql/statements/define/table#defining-permissions
More Surrealdb vulnerabilities
- TI-2026-45344 SurrealDB before 3.1.0 Session Hijacking via /rpc sessions CVSS 4.0HIGH 8.7
- TI-2024-38452 SurrealDB before 1.1.0 Denial of Service via HTTP Headers CVSS 4.0HIGH 8.7
- TI-2026-45347 SurrealDB before 3.1.0 Denial of Service via JSON Parser CVSS 4.0HIGH 8.7
- TI-2026-45334 SurrealDB before 3.1.0 Denial of Service via malformed RPC use CVSS 4.0HIGH 8.7
- TI-2025-43508 SurrealDB before 2.2.2 SurrealQL Injection via export CVSS 4.0CRITICAL 9.4
- TI-2026-45343 SurrealDB before 3.1.0 Privilege Escalation via RPC Session Race Condition CVSS 4.0CRITICAL 9.2
Sources
- CVE-2024-58367 · CVE Program
- CVE-2024-58367 · NVD
- FIRST EPSS
- GHSA-9722-9j67-vjcr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences