Etcd pkg Insecure ciphers are allowed by default
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
### Vulnerability type Cryptography ### Detail The TLS ciphers list supported by etcd contains insecure cipher suites. Users can configure the desired ciphers using the “--cipher-suites” flag, and a default list of secure cipher suites is used if empty. ### Workarounds By default, no action is required. If users want to specify cipher suites using the '--cipher-suites' flag, they should try not to specify insecure cipher suites. Please refer to the [security documentation](https://etcd.io/docs/v3.4/op-guide/security/). ### References Find out more on this vulnerability in the [security audit report](https://github.com/etcd-io/etcd/blob/main/security/SECURITY_AUDIT.pdf) ### For more information If you have any questions or comments about this advisory: * Contact the [etcd security committee](https://github.com/etcd-io/etcd/blob/main/security/security-release-process.md#product-security-committee-psc)
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | go.etcd.io/etcd/client/pkg/v3 (Go) | 3.4.0-rc.0 to before 3.4.10 | 3.4.10 | Patch available | GHSA-5x4g-q5rc-36jp |
| — | go.etcd.io/etcd/client/pkg/v3 (Go) | before 3.3.23 | 3.3.23 | Patch available | GHSA-5x4g-q5rc-36jp |
- go.etcd.io/etcd/client/pkg/v3 (Go) Vendor— Affected 3.4.0-rc.0 to before 3.4.10 Fixed in 3.4.10 Patch available GHSA-5x4g-q5rc-36jp
- go.etcd.io/etcd/client/pkg/v3 (Go) Vendor— Affected before 3.3.23 Fixed in 3.3.23 Patch available GHSA-5x4g-q5rc-36jp
Remediation
- Fix · GHSA-5x4g-q5rc-36jp go.etcd.io/etcd/client/pkg/v3 (Go) Fixed in 3.4.10 Advisory →
- Fix · GHSA-5x4g-q5rc-36jp go.etcd.io/etcd/client/pkg/v3 (Go) Fixed in 3.3.23 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-5x4g-q5rc-36jp
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences