commonground-api-common unexploitable privilege escalation in JWT authentication middleware
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- No fix listed
No CVSS vector from any source. Fix status from GitHub.
Summary
### Impact This is a privilege escalation vulnerability. The impact is negligible and entirely theoretical. A non-exploitable weakness was found in how the client-supplied JWTs are verified. Because an explicit allow-list of known algorithms is used in the PyJWT library, user-supplied (invalid) algorithms are rejected. If this was not the case, then the client JWTs could be tampered with, resulting in privilege escalation which would allow the attacker to perform any operation as any client (impersonation) without leaving a trace of the real user/client. ### Patches Will be fixed in 1.12.2 ### Workarounds None needed. But be careful when updating PyJWT. Check that the used PyJWT has no algorithms specified with a name in "", "HS25", "HS2", "HS", "H", or that those algorithms are acceptable. ### Details The header and payload of JSON Web Tokens (JWTs) are cryptographically signed with an algorithm. A JWT has a header field `alg` that specifies the algorithm used in the signature. The `vng-api-common.middleware.AuthMiddleware` uses PyJWT to check the validity of JWT and indicates it should be "HS256", otherwise an attacker could construct a token with a cryptographically weak token. It should indicate this with a list of acceptable algorithms `["HS256"]`, but instead the string `"HS256"` is passed to PyJWT. PyJWT does not check the type of the argument and checks if the `alg` string in the header exists in the acceptable algorithms value with the `in` operator. Any substring of `"HS256"` passes this `in` check. It is not exploitable because there is no such substring in de set of algorithms PyJWT supports.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | commonground-api-common (PyPI) | up to 1.12.1 | — | No fix listed | GHSA-c4cm-r9fh-jgj9 |
| — | vng-api-common (PyPI) | up to 2.0.5 | — | No fix listed | GHSA-c4cm-r9fh-jgj9 |
| — | vng-api-common-utrecht (PyPI) | up to 1.3.2 | — | No fix listed | GHSA-c4cm-r9fh-jgj9 |
- commonground-api-common (PyPI) Vendor— Affected up to 1.12.1 Fixed in — No fix listed GHSA-c4cm-r9fh-jgj9
- vng-api-common (PyPI) Vendor— Affected up to 2.0.5 Fixed in — No fix listed GHSA-c4cm-r9fh-jgj9
- vng-api-common-utrecht (PyPI) Vendor— Affected up to 1.3.2 Fixed in — No fix listed GHSA-c4cm-r9fh-jgj9
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-03 Threatist record created from GHSA-c4cm-r9fh-jgj9
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences