Magento LTS vulnerable to stored XSS in admin file form
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.
Summary
### Summary OpenMage is affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a low-privileged attacker to inject malicious scripts into vulnerable form fields. ### Details `Mage_Adminhtml_Block_System_Config_Form_Field_File` does not escape filename value in certain situations. Same as: https://nvd.nist.gov/vuln/detail/CVE-2024-20717 ### PoC 1. Create empty file with this filename: `<img src=x onerror=alert(1)>.crt` 2. Go to _System_ > _Configuration_ > _Sales | Payment Methonds_. 3. Click **Configure** on _PayPal Express Checkout_. 4. Choose **API Certificate** from dropdown _API Authentication Methods_. 5. Choose the XSS-file and click **Save Config**. 6. Profit, alerts "1" -> XSS. 7. Reload, alerts "1" -> Stored XSS. ### Impact Affects admins that have access to any fileupload field in admin in core or custom implementations. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | openmage/magento-lts (Packagist) | 20.0.0 to before 20.5.0 | 20.5.0 | Patch available | GHSA-gp6m-fq6h-cjcx |
| — | openmage/magento-lts (Packagist) | before 19.5.3 | 19.5.3 | Patch available | GHSA-gp6m-fq6h-cjcx |
- openmage/magento-lts (Packagist) Vendor— Affected 20.0.0 to before 20.5.0 Fixed in 20.5.0 Patch available GHSA-gp6m-fq6h-cjcx
- openmage/magento-lts (Packagist) Vendor— Affected before 19.5.3 Fixed in 19.5.3 Patch available GHSA-gp6m-fq6h-cjcx
Remediation
- Fix · GHSA-gp6m-fq6h-cjcx openmage/magento-lts (Packagist) Fixed in 20.5.0 Advisory →
- Fix · GHSA-gp6m-fq6h-cjcx openmage/magento-lts (Packagist) Fixed in 19.5.3 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-gp6m-fq6h-cjcx
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences