Read the docs
TI-2024-38549 Aliases GHSA-w8gf-g2vq-j2f4

amphp/http-client Denial of Service via HTTP/2 CONTINUATION Frames

Priority LOW 38CWE-770Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Denial of service
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-770.

Summary

Early versions of `amphp/http-client` with HTTP/2 support (v4.0.0-rc10 to 4.0.0) will collect HTTP/2 `CONTINUATION` frames in an unbounded buffer and will not check the header size limit until it has received the `END_HEADERS` flag, resulting in an OOM crash. Later versions of `amphp/http-client` (v4.1.0-rc1 and up) depend on `amphp/http` for HTTP/2 processing and will therefore need an updated version of `amphp/http`, see [GHSA-qjfw-cvjf-f4fm](https://github.com/amphp/http/security/advisories/GHSA-qjfw-cvjf-f4fm). ## Acknowledgements Thank you to [Bartek Nowotarski](https://nowotarski.info/) for reporting the vulnerability.

Why it matters now

Fix Fixed amphp/http-client (Packagist): 4.1.0-rc1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—amphp/http-client (Packagist)4.0.0-rc10 to before 4.1.0-rc14.1.0-rc1Patch availableGHSA-w8gf-g2vq-j2f4
  • amphp/http-client (Packagist) Vendor— Affected 4.0.0-rc10 to before 4.1.0-rc1 Fixed in 4.1.0-rc1 Patch available GHSA-w8gf-g2vq-j2f4

Remediation

  • Fix · GHSA-w8gf-g2vq-j2f4 amphp/http-client (Packagist) Fixed in 4.1.0-rc1 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-w8gf-g2vq-j2f4

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences