Read the docs
TI-2024-38555 Aliases GHSA-mc39-h54g-pvw6

libdav1d-sys affected by dav1d AV1 decoder integer overflow

Priority LOW 38CWE-190Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

An integer overflow in dav1d AV1 decoder that can occur when decoding videos with large frame size. This can lead to memory corruption within the AV1 decoder. We recommend upgrading to version 0.7.0 of libdav1d-sys, which includes dav1d 1.4.0.

Why it matters now

Fix Fixed libdav1d-sys (crates.io): 0.7.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—libdav1d-sys (crates.io)before 0.7.00.7.0Patch availableGHSA-mc39-h54g-pvw6
  • libdav1d-sys (crates.io) Vendor— Affected before 0.7.0 Fixed in 0.7.0 Patch available GHSA-mc39-h54g-pvw6

Remediation

  • Fix · GHSA-mc39-h54g-pvw6 libdav1d-sys (crates.io) Fixed in 0.7.0 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-mc39-h54g-pvw6

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences