dbt uses a SQLparse version with a high vulnerability
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
### Summary Using a version of `sqlparse` that has a security vulnerability and no way to update in current version of dbt core. Snyk recommends using `sqlparse==0.5` but this causes a conflict with dbt. Snyk states the issues is a recursion error: `SNYK-PYTHON-SQLPARSE-6615674`. ### Details Dependency conflict error message: ```sh The conflict is caused by: The user requested sqlparse==0.5 dbt-core 1.7.10 depends on sqlparse<0.5 and >=0.2.3 ``` Resolution was to pin `sqlparse >=0.5.0, <0.6.0` in `dbt-core`, patched in 1.6.13 and 1.7.13. ### PoC From Snyk: ```python import sqlparse sqlparse.parse('[' * 10000 + ']' * 10000) ``` ### Impact Snyk classifies it as high 7.5/10. ### Patches The bug has been fixed in [dbt-core v1.6.13](https://github.com/dbt-labs/dbt-core/releases/tag/v1.6.13) and [dbt-core v1.7.13](https://github.com/dbt-labs/dbt-core/releases/tag/v1.7.13). ### Mitigations Bump `dbt-core` 1.6 and 1.7 dependencies to 1.6.13 and 1.7.13 respectively
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | dbt-core (PyPI) | 1.6.0 to before 1.6.13 | 1.6.13 | Patch available | GHSA-p72q-h37j-3hq7 |
| — | dbt-core (PyPI) | 1.7.0 to before 1.7.13 | 1.7.13 | Patch available | GHSA-p72q-h37j-3hq7 |
- dbt-core (PyPI) Vendor— Affected 1.6.0 to before 1.6.13 Fixed in 1.6.13 Patch available GHSA-p72q-h37j-3hq7
- dbt-core (PyPI) Vendor— Affected 1.7.0 to before 1.7.13 Fixed in 1.7.13 Patch available GHSA-p72q-h37j-3hq7
Remediation
- Fix · GHSA-p72q-h37j-3hq7 dbt-core (PyPI) Fixed in 1.6.13 Advisory →
- Fix · GHSA-p72q-h37j-3hq7 dbt-core (PyPI) Fixed in 1.7.13 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-p72q-h37j-3hq7
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences