Pimcore TinyMCE Bundle - tinymce CVE-2024-29203, CVE-2024-29881
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.
Summary
### Impact The TineMCE Bundle uses tinymce version 6.7.3. CVEs for this version exists for <6.8.1: https://nvd.nist.gov/vuln/detail/CVE-2024-29203 https://nvd.nist.gov/vuln/detail/CVE-2024-29881 ### Patches The package should be updated to at least 6.8.1 to avoid XSS vulnerability. ### Workarounds Upgrade pimcore to release 11.2.3 or 11.1.6.5. ### References https://nvd.nist.gov/vuln/detail/CVE-2024-29203 https://nvd.nist.gov/vuln/detail/CVE-2024-29881
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | pimcore/pimcore (Packagist) | 11.2.0 to before 11.2.3 | 11.2.3 | Patch available | GHSA-vjwg-28gv-pm8h |
| — | pimcore/pimcore (Packagist) | 11.0.0-ALPHA1 to before 11.1.6.5 | 11.1.6.5 | Patch available | GHSA-vjwg-28gv-pm8h |
- pimcore/pimcore (Packagist) Vendor— Affected 11.2.0 to before 11.2.3 Fixed in 11.2.3 Patch available GHSA-vjwg-28gv-pm8h
- pimcore/pimcore (Packagist) Vendor— Affected 11.0.0-ALPHA1 to before 11.1.6.5 Fixed in 11.1.6.5 Patch available GHSA-vjwg-28gv-pm8h
Remediation
- Fix · GHSA-vjwg-28gv-pm8h pimcore/pimcore (Packagist) Fixed in 11.2.3 Advisory →
- Fix · GHSA-vjwg-28gv-pm8h pimcore/pimcore (Packagist) Fixed in 11.1.6.5 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-vjwg-28gv-pm8h
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences