Read the docs
TI-2024-38593 Aliases GHSA-wxxw-5gq6-j2g5

contao/core Insufficient input validation allows for code injection and remote execution

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

contao/core versions 2.x prior to 2.11.17 and 3.x prior to 3.2.9 are vulnerable to arbitrary code execution on the server due to insufficient input validation. In fact, attackers can remove or change pathconfig.php by entering a URL, meaning that the entire Contao installation will no longer be accessible or malicious code can be executed.

Why it matters now

Fix Fixed contao/core (Packagist): 2.11.17, 3.2.9

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—contao/core (Packagist)2.0.0 to before 2.11.172.11.17Patch availableGHSA-wxxw-5gq6-j2g5
—contao/core (Packagist)3.0.0 to before 3.2.93.2.9Patch availableGHSA-wxxw-5gq6-j2g5
  • contao/core (Packagist) Vendor— Affected 2.0.0 to before 2.11.17 Fixed in 2.11.17 Patch available GHSA-wxxw-5gq6-j2g5
  • contao/core (Packagist) Vendor— Affected 3.0.0 to before 3.2.9 Fixed in 3.2.9 Patch available GHSA-wxxw-5gq6-j2g5

Remediation

  • Fix · GHSA-wxxw-5gq6-j2g5 contao/core (Packagist) Fixed in 2.11.17 Advisory →
  • Fix · GHSA-wxxw-5gq6-j2g5 contao/core (Packagist) Fixed in 3.2.9 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-wxxw-5gq6-j2g5

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences