Read the docs
TI-2024-38598 Aliases GHSA-6q9v-4hq6-5m67

Doctrine SQL injection vulnerability

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

Doctrine is prone to SQL injection vulnerability. Users of Doctrine 1.2 and 2 should update to the newly released versions of both libraries immediately. Both versions only include the security fix and no other changes to their previous versions 1.2.3 and 2.0.2. Affected versions are: - 1.2.3 and earlier for PostgreSQL and DB2 Dialects - 2.0.2 and earlier The security issue was found to affect the `Doctrine\DBAL\Platforms\AbstractPlatform::modifyLimitQuery()` function which does not cast input values for limit and offset to integer and allows malicious SQL to be executed if these parameters are passed into Doctrine 2 directly from request variables without previous cast to integer. Functionality building on top using limit queries in the ORM such as `Doctrine\ORM\Query::setFirstResult()` and `Doctrine\ORM\Query::setMaxResults()` are also affected by this security issue. The fix for this security issue breaks backwards compatibility for developers that extend the `Doctrine\DBAL\Platforms\AbstractPlatform::modifyLimitQuery()` method, because it is now marked as final. Please overwrite the `Doctrine\DBAL\Platforms\AbstractPlatform::doModifyLimitQuery()` method instead.

Why it matters now

Fix Fixed doctrine/orm (Packagist): 2.0.3, 1.2.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—doctrine/orm (Packagist)2.0.0 to before 2.0.32.0.3Patch availableGHSA-6q9v-4hq6-5m67
—doctrine/orm (Packagist)1.0.0 to before 1.2.41.2.4Patch availableGHSA-6q9v-4hq6-5m67
  • doctrine/orm (Packagist) Vendor— Affected 2.0.0 to before 2.0.3 Fixed in 2.0.3 Patch available GHSA-6q9v-4hq6-5m67
  • doctrine/orm (Packagist) Vendor— Affected 1.0.0 to before 1.2.4 Fixed in 1.2.4 Patch available GHSA-6q9v-4hq6-5m67

Remediation

  • Fix · GHSA-6q9v-4hq6-5m67 doctrine/orm (Packagist) Fixed in 2.0.3 Advisory →
  • Fix · GHSA-6q9v-4hq6-5m67 doctrine/orm (Packagist) Fixed in 1.2.4 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-6q9v-4hq6-5m67

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences