Drupal Core Insufficient Contextual Links validation leads to Remote Code Execution
Priority LOW 38CWE-94Published · Updated
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Code execution
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-94.
Summary
The Contextual Links module doesn't sufficiently validate the requested contextual links. This vulnerability is mitigated by the fact that an attacker must have a role with the permission "access contextual links".
Why it matters now
Fix Fixed drupal/core (Packagist): 8.5.8, 8.6.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | drupal/core (Packagist) | 8.0.0 to before 8.5.8 | 8.5.8 | Patch available | GHSA-7v68-3pr5-h3cr |
| — | drupal/core (Packagist) | 8.6.0 to before 8.6.2 | 8.6.2 | Patch available | GHSA-7v68-3pr5-h3cr |
- drupal/core (Packagist) Vendor— Affected 8.0.0 to before 8.5.8 Fixed in 8.5.8 Patch available GHSA-7v68-3pr5-h3cr
- drupal/core (Packagist) Vendor— Affected 8.6.0 to before 8.6.2 Fixed in 8.6.2 Patch available GHSA-7v68-3pr5-h3cr
Remediation
- Fix · GHSA-7v68-3pr5-h3cr drupal/core (Packagist) Fixed in 8.5.8 Advisory →
- Fix · GHSA-7v68-3pr5-h3cr drupal/core (Packagist) Fixed in 8.6.2 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-7v68-3pr5-h3cr
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences