Drupal core Access bypass
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
The Media Library module has a security vulnerability whereby it doesn't sufficiently restrict access to media items in certain configurations. Solution: If you are using Drupal 8.7.x, you should upgrade to Drupal 8.7.11. If you are using Drupal 8.8.x, you should upgrade to Drupal 8.8.1. Versions of Drupal 8 prior to 8.7.x are end-of-life and do not receive security coverage. Alternatively, you may mitigate this vulnerability by unchecking the "Enable advanced UI" checkbox on `/admin/config/media/media-library`. (This mitigation is not available in 8.7.x.)
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | drupal/core (Packagist) | 8.0.0 to before 8.7.11 | 8.7.11 | Patch available | GHSA-mh4h-27gq-cxwj |
| — | drupal/core (Packagist) | 8.8.0 to before 8.8.1 | 8.8.1 | Patch available | GHSA-mh4h-27gq-cxwj |
- drupal/core (Packagist) Vendor— Affected 8.0.0 to before 8.7.11 Fixed in 8.7.11 Patch available GHSA-mh4h-27gq-cxwj
- drupal/core (Packagist) Vendor— Affected 8.8.0 to before 8.8.1 Fixed in 8.8.1 Patch available GHSA-mh4h-27gq-cxwj
Remediation
- Fix · GHSA-mh4h-27gq-cxwj drupal/core (Packagist) Fixed in 8.7.11 Advisory →
- Fix · GHSA-mh4h-27gq-cxwj drupal/core (Packagist) Fixed in 8.8.1 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-mh4h-27gq-cxwj
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences