Drupal core Arbitrary PHP code execution
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Code execution
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-94.
Summary
The Drupal project uses the PEAR Archive_Tar library. The PEAR Archive_Tar library has released a security update that impacts Drupal. For more information please see: CVE-2020-28948 CVE-2020-28949 Multiple vulnerabilities are possible if Drupal is configured to allow .tar, .tar.gz, .bz2, or .tlz file uploads and processes them. To mitigate this issue, prevent untrusted users from uploading .tar, .tar.gz, .bz2, or .tlz files.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | drupal/core (Packagist) | 7.0.0 to before 7.75 | 7.75 | Patch available | GHSA-gxxj-g9v8-w28p |
| — | drupal/core (Packagist) | 8.0.0 to before 8.8.12 | 8.8.12 | Patch available | GHSA-gxxj-g9v8-w28p |
| — | drupal/core (Packagist) | 8.9.0 to before 8.9.10 | 8.9.10 | Patch available | GHSA-gxxj-g9v8-w28p |
| — | drupal/core (Packagist) | 9.0.0 to before 9.0.9 | 9.0.9 | Patch available | GHSA-gxxj-g9v8-w28p |
- drupal/core (Packagist) Vendor— Affected 7.0.0 to before 7.75 Fixed in 7.75 Patch available GHSA-gxxj-g9v8-w28p
- drupal/core (Packagist) Vendor— Affected 8.0.0 to before 8.8.12 Fixed in 8.8.12 Patch available GHSA-gxxj-g9v8-w28p
- drupal/core (Packagist) Vendor— Affected 8.9.0 to before 8.9.10 Fixed in 8.9.10 Patch available GHSA-gxxj-g9v8-w28p
- drupal/core (Packagist) Vendor— Affected 9.0.0 to before 9.0.9 Fixed in 9.0.9 Patch available GHSA-gxxj-g9v8-w28p
Remediation
- Fix · GHSA-gxxj-g9v8-w28p drupal/core (Packagist) Fixed in 7.75 Advisory →
- Fix · GHSA-gxxj-g9v8-w28p drupal/core (Packagist) Fixed in 8.8.12 Advisory →
- Fix · GHSA-gxxj-g9v8-w28p drupal/core (Packagist) Fixed in 8.9.10 Advisory →
- Fix · GHSA-gxxj-g9v8-w28p drupal/core (Packagist) Fixed in 9.0.9 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-gxxj-g9v8-w28p
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences