Read the docs
TI-2024-38612 Aliases GHSA-vfgc-c76h-mwh4

Drupal core Cross-Site Scripting (XSS) vulnerabilities

Priority LOW 38CWE-79Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Cross-site scripting
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.

Summary

The Drupal project uses the CKEditor, library for WYSIWYG editing. CKEditor has released a security update that impacts Drupal. Vulnerabilities are possible if Drupal is configured to allow use of the CKEditor library for WYSIWYG editing. An attacker that can create or edit content (even without access to CKEditor themselves) may be able to exploit one or more Cross-Site Scripting (XSS) vulnerabilities to target users with access to the WYSIWYG CKEditor, including site admins with privileged access.

Why it matters now

Fix Fixed drupal/core (Packagist): 8.9.18, 9.1.12, 9.2.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—drupal/core (Packagist)8.0.0 to before 8.9.188.9.18Patch availableGHSA-vfgc-c76h-mwh4
—drupal/core (Packagist)9.1.0 to before 9.1.129.1.12Patch availableGHSA-vfgc-c76h-mwh4
—drupal/core (Packagist)9.2.0 to before 9.2.49.2.4Patch availableGHSA-vfgc-c76h-mwh4
  • drupal/core (Packagist) Vendor— Affected 8.0.0 to before 8.9.18 Fixed in 8.9.18 Patch available GHSA-vfgc-c76h-mwh4
  • drupal/core (Packagist) Vendor— Affected 9.1.0 to before 9.1.12 Fixed in 9.1.12 Patch available GHSA-vfgc-c76h-mwh4
  • drupal/core (Packagist) Vendor— Affected 9.2.0 to before 9.2.4 Fixed in 9.2.4 Patch available GHSA-vfgc-c76h-mwh4

Remediation

  • Fix · GHSA-vfgc-c76h-mwh4 drupal/core (Packagist) Fixed in 8.9.18 Advisory →
  • Fix · GHSA-vfgc-c76h-mwh4 drupal/core (Packagist) Fixed in 9.1.12 Advisory →
  • Fix · GHSA-vfgc-c76h-mwh4 drupal/core (Packagist) Fixed in 9.2.4 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-vfgc-c76h-mwh4

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences