Drupal Core Insufficient Contextual Links validation leads to Remote Code Execution
Priority LOW 38CWE-20Published · Updated
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
The Contextual Links module doesn't sufficiently validate the requested contextual links. This vulnerability is mitigated by the fact that an attacker must have a role with the permission "access contextual links".
Why it matters now
Fix Fixed drupal/drupal (Packagist): 8.5.8, 8.6.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | drupal/drupal (Packagist) | 8.0.0 to before 8.5.8 | 8.5.8 | Patch available | GHSA-jjx7-8462-w4m4 |
| — | drupal/drupal (Packagist) | 8.6.0 to before 8.6.2 | 8.6.2 | Patch available | GHSA-jjx7-8462-w4m4 |
- drupal/drupal (Packagist) Vendor— Affected 8.0.0 to before 8.5.8 Fixed in 8.5.8 Patch available GHSA-jjx7-8462-w4m4
- drupal/drupal (Packagist) Vendor— Affected 8.6.0 to before 8.6.2 Fixed in 8.6.2 Patch available GHSA-jjx7-8462-w4m4
Remediation
- Fix · GHSA-jjx7-8462-w4m4 drupal/drupal (Packagist) Fixed in 8.5.8 Advisory →
- Fix · GHSA-jjx7-8462-w4m4 drupal/drupal (Packagist) Fixed in 8.6.2 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-jjx7-8462-w4m4
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences