Read the docs
TI-2024-38628 Aliases GHSA-jq9q-6p42-qpr7

Cross-site Scripting (XSS) in DemoBundle/ezdemo bundled VideoJS

Priority LOW 38CWE-79Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Cross-site scripting
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.

Summary

his Security Advisory is about a vulnerability in VideoJS, which is bundled in DemoBundle and the ezdemo legacy extension. Older releases of VideoJS contain an XSS vulnerability in the Flash-based video player. This is bundled in DemoBundle, and in the Legacy "ezdemo" and "ezdemo-ls-extension" extensions. Among the branches still receiving security advisories, only eZ Publish Platform 5.4 and eZ Publish Legacy 5.4 are affected. However, it may be possible to make this software work in newer branches, so please check whether you have it installed even if you're using eZ Platform 1.x or 2.x. Because DemoBundle / ezdemo are only intended for demo purposes, they are not supported software. For that reason, and given the old age of the software, and manpower issues during the Coronavirus crisis, we are taking the unusual step of simply removing the affected file. This resolves the vulnerability, but also breaks the video playback feature. It may be possible to make it work again by upgrading to a current version of VideoJS, but it is unlikely that we will do this, given the reasons already mentioned.

Why it matters now

Fix Fixed ezsystems/ezdemo-ls-extension (Packagist): 5.4.2.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—ezsystems/ezdemo-ls-extension (Packagist)5.4.0 to before 5.4.2.15.4.2.1Patch availableGHSA-jq9q-6p42-qpr7
  • ezsystems/ezdemo-ls-extension (Packagist) Vendor— Affected 5.4.0 to before 5.4.2.1 Fixed in 5.4.2.1 Patch available GHSA-jq9q-6p42-qpr7

Remediation

  • Fix · GHSA-jq9q-6p42-qpr7 ezsystems/ezdemo-ls-extension (Packagist) Fixed in 5.4.2.1 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-jq9q-6p42-qpr7

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences