Cross-site Scripting in eZFind spellcheck
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.
Summary
This security advisory fixes a vulnerability in the legacy eZ Find extension, which can be used with the LegacyBridge in eZ Platform. It affects sites using the "Did you mean...?" spell check / search suggestion feature. This feature is vulnerable to Cross-site Scripting (XSS) injection (reflected XSS). The update adds the necessary escaping of injected code. If you're affected, we recommend that you install it as soon as possible. If you have custom search templates, please make sure you update these as well. Ensure that "search_extras.spellcheck_collation" is followed by the "wash" operator, like this: {$search_extras.spellcheck_collation|wash} To install, use Composer to update to one of the "Resolving versions" mentioned above, or apply this patch manually: https://github.com/ezsystems/ezfind/commit/51c17ea9b1231c20db8221f34d01c649060f1e91
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | ezsystems/ezfind-ls (Packagist) | 2017.12.0 to before 2017.12.0.1 | 2017.12.0.1 | Patch available | GHSA-9cq2-pcgr-8h62 |
| — | ezsystems/ezfind-ls (Packagist) | 5.4.0 to before 5.4.11.1 | 5.4.11.1 | Patch available | GHSA-9cq2-pcgr-8h62 |
| — | ezsystems/ezfind-ls (Packagist) | 5.3.0 to before 5.3.6.1 | 5.3.6.1 | Patch available | GHSA-9cq2-pcgr-8h62 |
- ezsystems/ezfind-ls (Packagist) Vendor— Affected 2017.12.0 to before 2017.12.0.1 Fixed in 2017.12.0.1 Patch available GHSA-9cq2-pcgr-8h62
- ezsystems/ezfind-ls (Packagist) Vendor— Affected 5.4.0 to before 5.4.11.1 Fixed in 5.4.11.1 Patch available GHSA-9cq2-pcgr-8h62
- ezsystems/ezfind-ls (Packagist) Vendor— Affected 5.3.0 to before 5.3.6.1 Fixed in 5.3.6.1 Patch available GHSA-9cq2-pcgr-8h62
Remediation
- Fix · GHSA-9cq2-pcgr-8h62 ezsystems/ezfind-ls (Packagist) Fixed in 2017.12.0.1 Advisory →
- Fix · GHSA-9cq2-pcgr-8h62 ezsystems/ezfind-ls (Packagist) Fixed in 5.4.11.1 Advisory →
- Fix · GHSA-9cq2-pcgr-8h62 ezsystems/ezfind-ls (Packagist) Fixed in 5.3.6.1 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-9cq2-pcgr-8h62
References
Other 5
- https://github.com/ezsystems/ezfind/commit/51c17ea9b1231c20db8221f34d01c649060f1e91
- https://github.com/FriendsOfPHP/security-advisories/blob/master/ezsystems/ezfind-ls/2019-05-23-1.yaml
- https://github.com/ezsystems/ezfind
- https://share.ez.no/community-project/security-advisories/ezsa-2019-003-xss-in-ezfind-spellcheck
- https://web.archive.org/web/20210614183107/https://share.ez.no/community-project/security-advisories/ezsa-2019-003-xss-in-ezfind-spellcheck
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences