Read the docs
TI-2024-38640 Aliases GHSA-qhjc-hg94-245v

eZ Platform Prevent accepting app.php in URL in Platform.sh

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

The recommended rewrite rules in eZ Platform prevent users from including the front-controller script (normally "app.php") in URLs. This prevents certain vulnerabilities related to caching. However, this is not possible when using eZ Platform Cloud (i.e. running eZ Platform on the Platform.sh cloud service), nor can it be done within the .platform.app.yaml configuration file. Therefore we need to reject such requests in the application itself. This advisory adds the prevention within the front controller script itself. If you use eZ Platform Cloud / Platform.sh we recommend that you install this security update as soon as possible. It is distributed via Composer as ezsystems/ezplatform 1.7.9.1, and 1.13.5.1, and 2.5.4. This is the commit: https://github.com/ezsystems/ezplatform/commit/34ce86722b36a172e587068fe64a84faa7320cc2

Why it matters now

Fix Fixed ezsystems/ezplatform (Packagist): 2.5.4, 1.13.5.1, 1.7.9.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—ezsystems/ezplatform (Packagist)2.5.0 to before 2.5.42.5.4Patch availableGHSA-qhjc-hg94-245v
—ezsystems/ezplatform (Packagist)1.13.0 to before 1.13.5.11.13.5.1Patch availableGHSA-qhjc-hg94-245v
—ezsystems/ezplatform (Packagist)1.7.0 to before 1.7.9.11.7.9.1Patch availableGHSA-qhjc-hg94-245v
  • ezsystems/ezplatform (Packagist) Vendor— Affected 2.5.0 to before 2.5.4 Fixed in 2.5.4 Patch available GHSA-qhjc-hg94-245v
  • ezsystems/ezplatform (Packagist) Vendor— Affected 1.13.0 to before 1.13.5.1 Fixed in 1.13.5.1 Patch available GHSA-qhjc-hg94-245v
  • ezsystems/ezplatform (Packagist) Vendor— Affected 1.7.0 to before 1.7.9.1 Fixed in 1.7.9.1 Patch available GHSA-qhjc-hg94-245v

Remediation

  • Fix · GHSA-qhjc-hg94-245v ezsystems/ezplatform (Packagist) Fixed in 2.5.4 Advisory →
  • Fix · GHSA-qhjc-hg94-245v ezsystems/ezplatform (Packagist) Fixed in 1.13.5.1 Advisory →
  • Fix · GHSA-qhjc-hg94-245v ezsystems/ezplatform (Packagist) Fixed in 1.7.9.1 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-qhjc-hg94-245v

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences