eZ Publish Legacy Cross-site Scripting (XSS) in 'disabled module' error template
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.
Summary
This security advisory fixes a vulnerability in eZ Publish Legacy, and we recommend that you install it as soon as possible if you are using Legacy via the LegacyBridge. Installations where all modules are disabled may be vulnerable to XSS injection in the module name. This is a rare configuration, but we still recommend installing the update, which adds the necessary input washing. To install, use Composer to update to one of the "Resolving versions" mentioned above, or apply this patch manually: https://github.com/ezsystems/ezpublish-legacy/commit/4697bff700e8cf95d5847ea19dad3479a77b02d9
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | ezsystems/ezpublish-legacy (Packagist) | 2018.9.0 to before 2018.9.1.2 | 2018.9.1.2 | Patch available | GHSA-2vh3-cj9j-mcj5 |
| — | ezsystems/ezpublish-legacy (Packagist) | 2018.6.0 to before 2018.6.1.3 | 2018.6.1.3 | Patch available | GHSA-2vh3-cj9j-mcj5 |
| — | ezsystems/ezpublish-legacy (Packagist) | 2011.0.0 to before 2017.12.4.2 | 2017.12.4.2 | Patch available | GHSA-2vh3-cj9j-mcj5 |
| — | ezsystems/ezpublish-legacy (Packagist) | 5.4.0 to before 5.4.12.2 | 5.4.12.2 | Patch available | GHSA-2vh3-cj9j-mcj5 |
| — | ezsystems/ezpublish-legacy (Packagist) | 5.3.0 to before 5.3.12.5 | 5.3.12.5 | Patch available | GHSA-2vh3-cj9j-mcj5 |
- ezsystems/ezpublish-legacy (Packagist) Vendor— Affected 2018.9.0 to before 2018.9.1.2 Fixed in 2018.9.1.2 Patch available GHSA-2vh3-cj9j-mcj5
- ezsystems/ezpublish-legacy (Packagist) Vendor— Affected 2018.6.0 to before 2018.6.1.3 Fixed in 2018.6.1.3 Patch available GHSA-2vh3-cj9j-mcj5
- ezsystems/ezpublish-legacy (Packagist) Vendor— Affected 2011.0.0 to before 2017.12.4.2 Fixed in 2017.12.4.2 Patch available GHSA-2vh3-cj9j-mcj5
- ezsystems/ezpublish-legacy (Packagist) Vendor— Affected 5.4.0 to before 5.4.12.2 Fixed in 5.4.12.2 Patch available GHSA-2vh3-cj9j-mcj5
- ezsystems/ezpublish-legacy (Packagist) Vendor— Affected 5.3.0 to before 5.3.12.5 Fixed in 5.3.12.5 Patch available GHSA-2vh3-cj9j-mcj5
Remediation
- Fix · GHSA-2vh3-cj9j-mcj5 ezsystems/ezpublish-legacy (Packagist) Fixed in 2018.9.1.2 Advisory →
- Fix · GHSA-2vh3-cj9j-mcj5 ezsystems/ezpublish-legacy (Packagist) Fixed in 2018.6.1.3 Advisory →
- Fix · GHSA-2vh3-cj9j-mcj5 ezsystems/ezpublish-legacy (Packagist) Fixed in 2017.12.4.2 Advisory →
- Fix · GHSA-2vh3-cj9j-mcj5 ezsystems/ezpublish-legacy (Packagist) Fixed in 5.4.12.2 Advisory →
- Fix · GHSA-2vh3-cj9j-mcj5 ezsystems/ezpublish-legacy (Packagist) Fixed in 5.3.12.5 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-2vh3-cj9j-mcj5
References
Other 5
- https://github.com/ezsystems/ezpublish-legacy/commit/4697bff700e8cf95d5847ea19dad3479a77b02d9
- https://github.com/FriendsOfPHP/security-advisories/blob/master/ezsystems/ezpublish-legacy/2018-11-01-1.yaml
- https://github.com/ezsystems/ezpublish-legacy
- https://web.archive.org/web/20210614172734/http://share.ez.no/community-project/security-advisories/ezsa-2018-006-xss-vulnerability-in-disabled-module-error-template
- http://share.ez.no/community-project/security-advisories/ezsa-2018-006-xss-vulnerability-in-disabled-module-error-template
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences