Read the docs
TI-2024-38657 Aliases GHSA-8wx3-8m4x-g5h4

FOSUserBundle User Identity Validation Vulnerability

Priority LOW 38CWE-285Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Security bypass
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-285.

Summary

Versions of FOSUserBundle prior to 1.2.1 have been found to be vulnerable to a security issue related to user identity validation. Specifically, user refreshing was performed using the primary key instead of the username, leading to a potential security risk if a user is allowed to change their username. The fix in version 1.2.1 addresses this issue by loading the user using the primary key during refreshing.

Why it matters now

Fix Fixed friendsofsymfony/user-bundle (Packagist): 1.2.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—friendsofsymfony/user-bundle (Packagist)1.0.0 to before 1.2.11.2.1Patch availableGHSA-8wx3-8m4x-g5h4
  • friendsofsymfony/user-bundle (Packagist) Vendor— Affected 1.0.0 to before 1.2.1 Fixed in 1.2.1 Patch available GHSA-8wx3-8m4x-g5h4

Remediation

  • Fix · GHSA-8wx3-8m4x-g5h4 friendsofsymfony/user-bundle (Packagist) Fixed in 1.2.1 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-8wx3-8m4x-g5h4

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences