Read the docs
TI-2024-38663 Aliases GHSA-2ffv-r4r9-r8xr

Laravel RCE vulnerability in "cookie" session driver

Priority LOW 38CWE-94Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Code execution
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-94.

Summary

Application's using the "cookie" session driver were the primary applications affected by this vulnerability. Since we have not yet released a security release for the Laravel 5.5 version of the framework, we recommend that all applications running Laravel 5.5 and earlier do not use the "cookie" session driver in their production deployments. Regarding the vulnerability, applications using the "cookie" session driver that were also exposing an encryption oracle via their application were vulnerable to remote code execution. An encryption oracle is a mechanism where arbitrary user input is encrypted and the encrypted string is later displayed or exposed to the user. This combination of scenarios lets the user generate valid Laravel signed encryption strings for any plain-text string, thus allowing them to craft Laravel session payloads when an application is using the "cookie" driver. This fix prefixes cookie values with an HMAC hash of the cookie's name before encryption and then verifies a matching hash on decryption, making it impossible to craft a valid cookie payload even if an encryption oracle is exposed via the application.

Why it matters now

Fix Fixed illuminate/cookie (Packagist): 6.18.31, 7.22.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—illuminate/cookie (Packagist)4.1.0 to before 6.18.316.18.31Patch availableGHSA-2ffv-r4r9-r8xr
—illuminate/cookie (Packagist)7.0.0 to before 7.22.47.22.4Patch availableGHSA-2ffv-r4r9-r8xr
  • illuminate/cookie (Packagist) Vendor— Affected 4.1.0 to before 6.18.31 Fixed in 6.18.31 Patch available GHSA-2ffv-r4r9-r8xr
  • illuminate/cookie (Packagist) Vendor— Affected 7.0.0 to before 7.22.4 Fixed in 7.22.4 Patch available GHSA-2ffv-r4r9-r8xr

Remediation

  • Fix · GHSA-2ffv-r4r9-r8xr illuminate/cookie (Packagist) Fixed in 6.18.31 Advisory →
  • Fix · GHSA-2ffv-r4r9-r8xr illuminate/cookie (Packagist) Fixed in 7.22.4 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-2ffv-r4r9-r8xr

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences