Read the docs
TI-2024-38665 Aliases GHSA-297g-xg4h-7w4c

Laravel Cross-site Scripting vulnerability in blade templating

Priority LOW 38CWE-79Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Cross-site scripting
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.

Summary

Laravel is prone to a Cross-site Scripting vulnerability in blade templating.

Why it matters now

Fix Fixed illuminate/view (Packagist): 7.1.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—illuminate/view (Packagist)7.0.0 to before 7.1.27.1.2Patch availableGHSA-297g-xg4h-7w4c
  • illuminate/view (Packagist) Vendor— Affected 7.0.0 to before 7.1.2 Fixed in 7.1.2 Patch available GHSA-297g-xg4h-7w4c

Remediation

  • Fix · GHSA-297g-xg4h-7w4c illuminate/view (Packagist) Fixed in 7.1.2 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-297g-xg4h-7w4c

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences