Read the docs
TI-2024-38673 Aliases GHSA-vr95-p7q6-8m9q

Laravel Cross-site Scripting (XSS) vulnerability in blade templating

Priority LOW 38CWE-79Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Cross-site scripting
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.

Summary

Laravel 7.1.2 addresses a possible XSS related attack vector in the Laravel 7.x Blade Component tag attributes when users are allowed to dictate the value of attributes. All Laravel 7.x users are encouraged to upgrade as soon as possible.

Why it matters now

Fix Fixed laravel/framework (Packagist): 7.1.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—laravel/framework (Packagist)7.0.0 to before 7.1.27.1.2Patch availableGHSA-vr95-p7q6-8m9q
  • laravel/framework (Packagist) Vendor— Affected 7.0.0 to before 7.1.2 Fixed in 7.1.2 Patch available GHSA-vr95-p7q6-8m9q

Remediation

  • Fix · GHSA-vr95-p7q6-8m9q laravel/framework (Packagist) Fixed in 7.1.2 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-vr95-p7q6-8m9q

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences