laravel framework SQL Injection via limit and offset functions
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-89.
Summary
### Impact Those using SQL Server with Laravel and allowing user input to be passed directly to the limit and offset functions are vulnerable to SQL injection. Other database drivers such as MySQL and Postgres are not affected by this vulnerability. ### Patches This problem has been patched on Laravel versions 6.20.26, 7.30.5, and 8.40.0. ### Workarounds You may workaround this vulnerability by ensuring that only integers are passed to the limit and offset functions, as well as the skip and take functions.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | laravel/framework (Packagist) | 6.0.0 to before 6.20.26 | 6.20.26 | Patch available | GHSA-wq8p-mqvg-2p5h |
| — | laravel/framework (Packagist) | 7.0.0 to before 7.30.5 | 7.30.5 | Patch available | GHSA-wq8p-mqvg-2p5h |
| — | laravel/framework (Packagist) | 8.0.0 to before 8.40.0 | 8.40.0 | Patch available | GHSA-wq8p-mqvg-2p5h |
- laravel/framework (Packagist) Vendor— Affected 6.0.0 to before 6.20.26 Fixed in 6.20.26 Patch available GHSA-wq8p-mqvg-2p5h
- laravel/framework (Packagist) Vendor— Affected 7.0.0 to before 7.30.5 Fixed in 7.30.5 Patch available GHSA-wq8p-mqvg-2p5h
- laravel/framework (Packagist) Vendor— Affected 8.0.0 to before 8.40.0 Fixed in 8.40.0 Patch available GHSA-wq8p-mqvg-2p5h
Remediation
- Fix · GHSA-wq8p-mqvg-2p5h laravel/framework (Packagist) Fixed in 6.20.26 Advisory →
- Fix · GHSA-wq8p-mqvg-2p5h laravel/framework (Packagist) Fixed in 7.30.5 Advisory →
- Fix · GHSA-wq8p-mqvg-2p5h laravel/framework (Packagist) Fixed in 8.40.0 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-wq8p-mqvg-2p5h
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences