Read the docs
TI-2024-38678 Aliases GHSA-7fjv-25q9-2w88

State Guessing Vulnerability in laravel/socialite

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

laravel/socialite versions prior to 2.0.10 are susceptible to a security vulnerability related to state guessing during OAuth authentication. This vulnerability could potentially lead to session hijacking, allowing attackers to compromise user sessions. The issue has been addressed and fixed in version 2.0.10.

Why it matters now

Fix Fixed laravel/socialite (Packagist): 2.0.10

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—laravel/socialite (Packagist)1.0.0 to before 2.0.102.0.10Patch availableGHSA-7fjv-25q9-2w88
  • laravel/socialite (Packagist) Vendor— Affected 1.0.0 to before 2.0.10 Fixed in 2.0.10 Patch available GHSA-7fjv-25q9-2w88

Remediation

  • Fix · GHSA-7fjv-25q9-2w88 laravel/socialite (Packagist) Fixed in 2.0.10 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-7fjv-25q9-2w88

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences