Data Leakage Vulnerability in livewire/livewire
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-200.
Summary
livewire/livewire versions greater than 2.2.4 and less than 2.2.6 are affected by a data leakage vulnerability. The `$this->validate()` method, which is expected to return only the validated dataset, was returning all properties of the Livewire component. This regression introduced a security risk, allowing unvalidated data to be exposed, which could lead to unexpected behavior and potential security issues.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | livewire/livewire (Packagist) | 2.2.5 to before 2.2.6 | 2.2.6 | Patch available | GHSA-qwvp-268g-jjm8 |
- livewire/livewire (Packagist) Vendor— Affected 2.2.5 to before 2.2.6 Fixed in 2.2.6 Patch available GHSA-qwvp-268g-jjm8
Remediation
- Fix · GHSA-qwvp-268g-jjm8 livewire/livewire (Packagist) Fixed in 2.2.6 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-qwvp-268g-jjm8
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences