Magento Open Source Security Advisory: Patch SUPEE-10975
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
Magento Commerce 1.14.4.0 and Open Source 1.9.4.0 have been enhanced with critical security updates to address multiple vulnerabilities, including remote code execution (RCE), cross-site scripting (XSS), cross-site request forgery (CSRF), and more. The following issues have been identified and remediated: - PRODSECBUG-1589: Stops Brute Force Requests via basic RSS authentication - MAG-23: M1 Credit Card Storage Capability - PRODSECBUG-2149: Authenticated RCE using customer import - PRODSECBUG-2159: API Based RCE Vulnerability - PRODSECBUG-2156: RCE Via Unauthorized Upload - PRODSECBUG-2155: Authenticated RCE using dataflow - PRODSECBUG-2053: Prevents XSS in Newsletter Template - PRODSECBUG-2142: XSS in CMS Preview - PRODSECBUG-1860: Admin Account XSS Attack Cessation via Filename - PRODSECBUG-2119: EE Patch to include names in templates - PRODSECBUG-2129: XSS in Google Analytics Vulnerability - PRODSECBUG-2019: Merchant Wishlist Security Strengthening - PRODSECBUG-2104: Send to a Friend Vulnerability - PRODSECBUG-2125: CSRF on deletion of Blocks Vulnerability - PRODSECBUG-2088: CSRF Vulnerability related to Customer Group Deletion - PRODSECBUG-2140: CSRF on deletion of Site Map - PRODSECBUG-2108: Outdated jQuery causing PCI scanning failures - MAG-12, MAG-2: Encryption Keys Stored in Plain Text - PRODSECBUG-2141: Unauthorized Admin Panel Bypass ### Patching and Upgrading: Patches and upgrades are available for the following Magento versions: Magento Commerce 1.9.0.0-1.14.4.0: Apply SUPEE-10975 or upgrade to Magento Commerce 1.14.4.0. Magento Open Source 1.5.0.0-1.9.4.0: Apply SUPEE-10975 or upgrade to Magento Open Source 1.9.4.0.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | magento/community-edition (Packagist) | 1.9.0.0 to before 1.14.4.0 | 1.14.4.0 | Patch available | GHSA-cv25-3pxr-4q7x |
- magento/community-edition (Packagist) Vendor— Affected 1.9.0.0 to before 1.14.4.0 Fixed in 1.14.4.0 Patch available GHSA-cv25-3pxr-4q7x
Remediation
- Fix · GHSA-cv25-3pxr-4q7x magento/community-edition (Packagist) Fixed in 1.14.4.0 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-cv25-3pxr-4q7x
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences