Read the docs
TI-2024-38685 Aliases GHSA-5gmh-85x8-5cx7

Magento remote code execution (RCE), Cross-Site Scripting (XSS) and other vulnerabilities

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

Magento Commerce and Open Source 2.2.5 and 2.1.14 contain multiple security enhancements that help close authenticated Admin user remote code execution (RCE), Cross-Site Scripting (XSS) and other vulnerabilities.

Why it matters now

Fix Fixed magento/community-edition (Packagist): 2.1.14, 2.2.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—magento/community-edition (Packagist)2.1 to before 2.1.142.1.14Patch availableGHSA-5gmh-85x8-5cx7
—magento/community-edition (Packagist)2.2 to before 2.2.52.2.5Patch availableGHSA-5gmh-85x8-5cx7
  • magento/community-edition (Packagist) Vendor— Affected 2.1 to before 2.1.14 Fixed in 2.1.14 Patch available GHSA-5gmh-85x8-5cx7
  • magento/community-edition (Packagist) Vendor— Affected 2.2 to before 2.2.5 Fixed in 2.2.5 Patch available GHSA-5gmh-85x8-5cx7

Remediation

  • Fix · GHSA-5gmh-85x8-5cx7 magento/community-edition (Packagist) Fixed in 2.1.14 Advisory →
  • Fix · GHSA-5gmh-85x8-5cx7 magento/community-edition (Packagist) Fixed in 2.2.5 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-5gmh-85x8-5cx7

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences