Read the docs
TI-2024-38686 Aliases GHSA-mcfc-67vm-j568

Magento Cross-Site Scripting (XSS) vulnerability

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

Magento Commerce and Open Source 2.2.6 and 2.1.15 contain multiple security enhancements that help close Cross-Site Scripting (XSS) and other vulnerabilities.

Why it matters now

Fix Fixed magento/community-edition (Packagist): 2.1.15, 2.2.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—magento/community-edition (Packagist)2.1 to before 2.1.152.1.15Patch availableGHSA-mcfc-67vm-j568
—magento/community-edition (Packagist)2.2 to before 2.2.62.2.6Patch availableGHSA-mcfc-67vm-j568
  • magento/community-edition (Packagist) Vendor— Affected 2.1 to before 2.1.15 Fixed in 2.1.15 Patch available GHSA-mcfc-67vm-j568
  • magento/community-edition (Packagist) Vendor— Affected 2.2 to before 2.2.6 Fixed in 2.2.6 Patch available GHSA-mcfc-67vm-j568

Remediation

  • Fix · GHSA-mcfc-67vm-j568 magento/community-edition (Packagist) Fixed in 2.1.15 Advisory →
  • Fix · GHSA-mcfc-67vm-j568 magento/community-edition (Packagist) Fixed in 2.2.6 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-mcfc-67vm-j568

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences