Read the docs
TI-2024-38687 Aliases GHSA-8j7c-682x-r9f2

Magento RCE,XSS and other vulnerabilities

Priority LOW 38Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

Magento Commerce and Open Source 2.3.0, 2.2.7 and 2.1.16 contain multiple security enhancements that help close Remote Code Execution (RCE), Cross-Site Scripting (XSS) and other vulnerabilities.

Why it matters now

Fix Fixed magento/community-edition (Packagist): 2.1.16, 2.2.7

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—magento/community-edition (Packagist)2.1 to before 2.1.162.1.16Patch availableGHSA-8j7c-682x-r9f2
—magento/community-edition (Packagist)2.2 to before 2.2.72.2.7Patch availableGHSA-8j7c-682x-r9f2
  • magento/community-edition (Packagist) Vendor— Affected 2.1 to before 2.1.16 Fixed in 2.1.16 Patch available GHSA-8j7c-682x-r9f2
  • magento/community-edition (Packagist) Vendor— Affected 2.2 to before 2.2.7 Fixed in 2.2.7 Patch available GHSA-8j7c-682x-r9f2

Remediation

  • Fix · GHSA-8j7c-682x-r9f2 magento/community-edition (Packagist) Fixed in 2.1.16 Advisory →
  • Fix · GHSA-8j7c-682x-r9f2 magento/community-edition (Packagist) Fixed in 2.2.7 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-8j7c-682x-r9f2

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences