Read the docs
TI-2024-38740 Aliases GHSA-mqf5-275h-gf6r

Silverstripe framework is vulnerable to XSS in install.php

Priority LOW 38CWE-79Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Cross-site scripting
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-79.

Summary

During installation, certain parameters (admin_username and admin_password) are not escaped in the setup form. This issue is resolved in 3.1.14 stable, although existing users are advised to remove this file prior to deploying to a production server.

Why it matters now

Fix Fixed silverstripe/framework (Packagist): 3.1.14

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—silverstripe/framework (Packagist)3.1.0 to before 3.1.143.1.14Patch availableGHSA-mqf5-275h-gf6r
  • silverstripe/framework (Packagist) Vendor— Affected 3.1.0 to before 3.1.14 Fixed in 3.1.14 Patch available GHSA-mqf5-275h-gf6r

Remediation

  • Fix · GHSA-mqf5-275h-gf6r silverstripe/framework (Packagist) Fixed in 3.1.14 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-mqf5-275h-gf6r

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences